Jump to content


Photo

Local Network File Transfers Agent.exe Pegs At 100% Cpu


  • Please log in to reply
2 replies to this topic

#1 gary gabriel

gary gabriel

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 16 November 2012 - 07:41 AM

Hi

Accoring to Windows Task Monitor; Immunet agent.exe pegged at 100% CPU utilization while syncing the network server folder to the local folder over the network. It approx. 15 min to finish the copying of 20 mb.

Immunet configuration changes did not improve the situation.

Original Immunut settings:
- agent.exe could not be exited in Task Monitor.
- Clam AV ON Ethos ON Spero ON

Experimental Immunet config changes to try to achieve an acceptable configuration:
- Clam AV ON Ethos ON Spero ON ->
- Clam AV OFF Ethos ON Spero ON ->
- Clam AV OFF Ethos Off Spero Off

This was the result of a test. Yesterday while trying to configure rsync backups; Immunet agent.exe completely blocked while pegging at 100% utilization for 4 hours. There was no possibility to exit agent.exe with Task Monitor.

I also googled and searched the forum, but found no answers.

I hope someone can provide some settings to allow normal network traffic.

Thanks- Gary Gabriel
  • reahwhems likes this

#2 ritchie58

ritchie58

    Staff Member

  • Moderators
  • 1,973 posts
  • LocationOil City, Pa. U.S.A.

Posted 16 November 2012 - 09:37 AM

If you have large files to transfer try turning off "Blocking Mode" in settings. This will speed up the process but you will loose a little protection as these files will not be scanned for malware as they are being moved or copied. Another option would be to add the complete file paths for both the server folder & the local folder into Immunet's Exclusion List. If you find Immunet still slowing things to an unaccecptable level try turning off "Monitor Program Install" in Settings too. I would leave ETHOS & SPERO on as these are the cloud engines. If ClamAV doesn't slow things down too much I would recommend leaving that on along with Automatic Updates for ClamAV too (Free version). If you're using the Plus (paid) version enable the TETRA module and turn ClamAV off. Hope this helps. Regards, Ritchie...

* Immunet Global Forum Moderator *


#3 gary gabriel

gary gabriel

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 17 November 2012 - 06:25 AM

Thanks for your replay. I will try the settings you suggested. However I was not clear, did not make the severity of this problem clear yesterday and I have become more aware of what is generally going on.
1) The problem (for me) does not occur because of large files, but transferring or syncing directories (of numerous small files).
2) I have now monitored this problem generally. Agent.exe excessively slows down transfer of files. Individual file transfer is not as noticeable but becomes excessively slow. It also hogs excessive CPU resources according to Task Monitor.

In summary; I will try your excellant suggestions to see if they succeed in bringing file transfer to workable and acceptable levels.

Thanks- Gary




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users