Jump to content


Photo
* * * * * 1 votes

Immunet 3.1.8 Is Now Available


  • Please log in to reply
21 replies to this topic

#1 RobT

RobT

    Advanced Member

  • Administrators
  • 245 posts

Posted 31 December 2013 - 03:30 AM

Hi everyone, it's been a long time since our last release but it's finally ready! We've been heads down working on the FireAMP version of product for almost a year straight and in that time I'm sad to say we just haven't been able to give Immunet the attention it deserves. Well, no more! This release sync's Immunet up with our most current code base and fixes *tons* of bugs, adds numerous performance tweaks and enhancements, and updated virus scanning engines!

Please get it here:
http://download.immu...mmunetSetup.exe
This installer can be used for stand-alone installs or to upgrade any previous versions of Immunet you might already have installed.

Major Changes for 3.1.8 include:
*The "My Community" and "Notices" features have been removed from the UI. These became redundant long ago as we found a way for our Cloud Servers to ensure all users received the full protection of Immunet's global community of over 2 million users, rather than just the few immediate users most people had in their local communities.
*We're now "Immunet 3" instead of "Immunet 3.0". There are so many minor changes since our last major release that we've had to rev our version number.
*Full Windows 8 and Windows 8.1 support!
*New and improved versions of both the Tetra and Clam engines!
*Bug fixes for network related issues that would cause Net Bios name resolution failures, VPN connection failures, and BSOD’s.
*Bug fixes for XML locking issues.

We're especially happy about those last two as they've been causing 90% of the issues reported to us at support@immunet.com and through forum.immunet.com.

Reporting Issues:
As usual, if you have any feedback you'd like us to hear please post it to this thread. If you think you've found a bug please include a description of the problem, instructions to reproduce it, and any relevant screenshots.

#2 ritchie58

ritchie58

    Staff Member

  • Moderators
  • 1,958 posts
  • LocationOil City, Pa. U.S.A.

Posted 31 December 2013 - 06:01 AM

Hi RobT, glad to see you back on the forum after such a long hiatus! "Great!" On a more serious note I think I might be encountering a bug. Not sure. After updating the ClamAV defs of course and several attempts at a restart/Flash Scan the button next to Computer remains yellow (see image). Is this anything to be concerned about? Do I need to run a more comprehensive scan? I was helping to test the 3.1.8 beta (which seems to me, ran normal & stable btw, no issues encountered) and used a clean uninstall if that may have any bearing on the matter. Thought I'd mention that. Send in a SDT report? Other than that the install went smoothly and the program seems to be stable at the moment.

I do have one more question, is this build going to be hard pushed to users thruogh the GUI eventually. I'd like to see that so most users get this latest build update. I'm going to assume that will be the case sometime in the near future.

Really great to see this version has fixed the name resolution & VPN bugs and is now compatable with Windows 8 & 8.1! That means more users can now connect to the cloud. The more users in the cloud the better the protection for all!

Regards, Ritchie...

Attached Files


* Immunet Global Forum Moderator *


#3 spywar

spywar

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 31 December 2013 - 11:17 AM

Excellent !

BTW it seems like there is a problem with the main website

http://www.immunet.com/main/index.html

"The Immunet® Community has more than 2,285,427 members protected from 33,435,925 threats."

Are these stats correctly updated ? I don't have currently Immunet installed on my system, ritchie could you check out how many you have on your Immunet ?

Cheers,
spy
spywar
- Malware Hunter and BETA tester at Comodo Forums
- Staff member at Malwaretips Forums
Comodo Internet Security 6.3, Windows Vista SP2 64bit.

#4 ritchie58

ritchie58

    Staff Member

  • Moderators
  • 1,958 posts
  • LocationOil City, Pa. U.S.A.

Posted 31 December 2013 - 09:03 PM

Hi spywar, it's been a while since you last posted. I checked that link and I didn't have any problems accessing the site.

The GUI stats I get is 3,076,044 members protected from 56,913,851 threats.

Regards, Ritchie...

* Immunet Global Forum Moderator *


#5 Jose

Jose

    Advanced Member

  • Administrators
  • 104 posts

Posted 02 January 2014 - 06:22 PM

Spywar,

The website seems to be outdated there. I'll let the people who handle it know.

Ritchie,

It is possibly best if you send us an SDT to support@immunet.com (still an issue, I presume?)

And the update will get pushed through the GUI in the next few days as well.

Thanks,

-Jose

#6 RobT

RobT

    Advanced Member

  • Administrators
  • 245 posts

Posted 02 January 2014 - 09:44 PM

Thanks for the feedback so far!

Richie, I've seen the issue you're talking about but wasn't able to reproduce it so I chalked it up to me doing something poor testing. So yes please send the support dump!

Spywar - great catch. You are correct, the Community stats on our website are off by nearly 800K users and 25K threats. I have bugged this for our web dev.

#7 ritchie58

ritchie58

    Staff Member

  • Moderators
  • 1,958 posts
  • LocationOil City, Pa. U.S.A.

Posted 02 January 2014 - 10:51 PM

SDT report sent. Geez, I got an error message when trying to send the email a couple of times from my yahoo mail server. I had to remove the 7zip attachment and reload the attachment to the email again but that seemed to work. Never seen that before. I did just get a confirmation email so you guys did receive it, that's good.

* Immunet Global Forum Moderator *


#8 spywar

spywar

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 03 January 2014 - 01:52 PM

Thanks,

Is the number of users stats corresponding to ACTIVE users ? or only number of installations ? Just out of curiosity, to make sure...

Cheers,
spy
spywar
- Malware Hunter and BETA tester at Comodo Forums
- Staff member at Malwaretips Forums
Comodo Internet Security 6.3, Windows Vista SP2 64bit.

#9 ritchie58

ritchie58

    Staff Member

  • Moderators
  • 1,958 posts
  • LocationOil City, Pa. U.S.A.

Posted 04 January 2014 - 12:23 AM

Hello everyone, I just got confirmation that if you're a Free user that check mark will stay yellow. This is a reminder that there are some functions disabled with the Free version and as an encouragement to purchase a Plus key. So this is normal behavior with the 3.1.8 Free version after all. Not sure I personnaly like this change but that's the status quo. This will, in my opinion, cause some possible confusion for the Free users as it did me.

Regards, Ritchie...

* Immunet Global Forum Moderator *


#10 Zurchiboy

Zurchiboy

    Advanced Member

  • Members
  • PipPipPip
  • 105 posts

Posted 05 January 2014 - 08:14 PM

Congrats Immunet. Will be taking a look at it shortly.
  • ritchie58 likes this

#11 buckslayr

buckslayr

    Advanced Member

  • Immunet Insiders
  • PipPipPip
  • 68 posts
  • LocationUSA

Posted 06 January 2014 - 02:54 AM

I've been away from Immunet for a long time. Decided to give the new version a try and loved it so much that I bought a 3 pc license. Great job.
  • ritchie58 likes this
Immunet Protect 3.0 + AppGuard + ClearCloud DNS

#12 ritchie58

ritchie58

    Staff Member

  • Moderators
  • 1,958 posts
  • LocationOil City, Pa. U.S.A.

Posted 06 January 2014 - 10:38 PM

Hey buckslayr! It's been a while! I believe I've encountered an issue that may need looked into. After several reboots Imp was not launching correctly. I couldn't get the GUI to launch from the sys tray icon or right clicking on the sys tray icon did nothing too. After checking Process Lasso both iptray & sfc were being shown as running, active processes during these events. However by clicking on the "Desktop" icon I was able to launch the GUI then. At which time the Scan Now & Settings tabs were greyed out. First I created a support dump then I used Process Lasso to force terminate both sfc & iptray since I couldn't use the sys tray icon to kill iptray first. I then used the CMD command to relaunch sfc and used the Desktop icon to launch iptray again. That seemed to correct the issue for now. SDT report sent in. Case # 16110.

Edit: I have rebooted again and Immunet started normally this time. I'll consider that a good sign! Before this current bootup I did do a quick DskChk scan (no bad sectors detected), a through cleaning of junk files, cleaned & defragged the registry and defragged & compacted the entire C:\ drive. That always helps to keep things running lean & mean. (off topic I know, but, it's -11 below with a wind chill of -38 below 0 outside right now, B-r-r-r!)

Edited by ritchie58, 10 January 2014 - 10:11 PM.
Last Bootup

* Immunet Global Forum Moderator *


#13 fblais

fblais

    Advanced Member

  • Members
  • PipPipPip
  • 35 posts

Posted 10 January 2014 - 01:19 PM

Thanks!
Question: are the localized versions updated as well?
Last year, if I was choosing french, I was getting a 2.x version.
I needed to choose english to get the last version.

Best!
François

Windows 7 home premium SP1 x86, Immunet beta, MBAE free, Panda free


#14 Jose

Jose

    Advanced Member

  • Administrators
  • 104 posts

Posted 10 January 2014 - 07:03 PM

Hi François,

Getting the non-english language versions up-to-date is something we want to do, but it is not out there yet, unfortunately.

We will announce it as part of the release notes when it does.

Cheers,
-Jose

#15 fblais

fblais

    Advanced Member

  • Members
  • PipPipPip
  • 35 posts

Posted 11 January 2014 - 07:57 PM

Thanks Jose!

Windows 7 home premium SP1 x86, Immunet beta, MBAE free, Panda free


#16 ideapocket

ideapocket

    Newbie

  • Members
  • Pip
  • 1 posts
  • LocationTokyo / Japan

Posted 30 January 2014 - 08:45 PM

The windows 7 user is not need install immunet 3.1.8

#17 ritchie58

ritchie58

    Staff Member

  • Moderators
  • 1,958 posts
  • LocationOil City, Pa. U.S.A.

Posted 30 January 2014 - 10:13 PM

Are you having problems installing Immunet 3.1.8 on a Windows 7 machine? Am I understanding you correctly ideapocket? Immunet does use a bootstrapper installer so an active internet connection is required to download the necessary install files.

* Immunet Global Forum Moderator *


#18 spywar

spywar

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 24 March 2014 - 08:48 PM

Spywar,

The website seems to be outdated there. I'll let the people who handle it know.

Ritchie,

It is possibly best if you send us an SDT to support@immunet.com (still an issue, I presume?)

And the update will get pushed through the GUI in the next few days as well.

Thanks,

-Jose

Hello.

FYI, the issue is still present.

spywar
spywar
- Malware Hunter and BETA tester at Comodo Forums
- Staff member at Malwaretips Forums
Comodo Internet Security 6.3, Windows Vista SP2 64bit.

#19 Sveni

Sveni

    Member

  • Members
  • PipPip
  • 16 posts
  • LocationDresden, Germany

Posted 08 May 2014 - 04:38 PM

Hi Guys,
Thank you for v3 Immunet! I have now bought 3PC license.
Will test on WIN8.1 soon be(On my father's PC).
Have been no money spent on antivirus software.
Want this project but absolutely support :wub:

There are no problems, only your website is not up to date (screenshots, etc.)

Sorry for my Google Translate English :ph34r:

Best Regards from Saxony
Great job!
By Sveni
Win7 64bit latest, German Language
Immunet 3.1.8.9583
CPU i5-3570K, 4200 MHz
8GB RAM

#20 ritchie58

ritchie58

    Staff Member

  • Moderators
  • 1,958 posts
  • LocationOil City, Pa. U.S.A.

Posted 09 May 2014 - 02:32 AM

Hello Sveni, thank you for your interest in Immunet and the purchase of the Plus license key for your PC's!

You are right about some sites not being updated with current information in a while. The Admins are aware of this situation and I've been told that eventually these sites will be updated but I don't think it's real high on the list of priorities at the moment.

Cheers, Ritchie...

* Immunet Global Forum Moderator *





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users