Jump to content


Photo

Immunet5 Clamav Proxy

proxy clamav immunet5

  • Please log in to reply
5 replies to this topic

#1 seb

seb

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 29 September 2016 - 09:07 AM

Hi,

 

I have upgraded from Immunet3 to Immunet5 and I have a problem with the proxy settings on Windows 2012.

 

I never managed with Immunet3 to detect my proxy settings but by adding the following two lines in the freshclam.conf I was able to use my proxy at least for the signature updates.

 

HTTPProxyPort <port>
HTTPProxyServer <proxy hostname>

 

My proxy settings are still not detected on Immunet5 but now I can't modify the freshclam.conf as it is replaced by the default one everytime the service is restarted.

 

Is there a way to change this behaviour or a new method to detect the proxy settings (I checked with netsh winhttp show proxy and the proxy is set) ?

 

In advance thank you,


Edited by seb, 29 September 2016 - 09:14 AM.


#2 ritchie58

ritchie58

    Staff Member

  • Moderators
  • 1,811 posts
  • LocationOil City, Pa. U.S.A.

Posted 30 September 2016 - 03:44 AM

May I suggest you submit your inquiry directly to support at this address support@immunet.com. Include all pertinent data related to the issue including any screen shots you may have in your email. Also mention in your email that you started a topic in this forum section.

 

Best wishes, Ritchie...


* Immunet Global Forum Moderator *


#3 seb

seb

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 30 September 2016 - 08:16 AM

Thank you. I sent a mail to the support.

 

Regards,



#4 nwn

nwn

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 09 November 2016 - 10:15 AM

Hi @Seb, did you solve the issue with freshclam.conf? I have the same problem because conf is locked by Immunet process and Im not able to set proxy for clamav updates neither for custom database URL(custom signature URL).



#5 socuteboy

socuteboy

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 20 December 2016 - 10:58 AM

If immunet does not detect your proxy, you have to declare it with winhttp or import it from the internet explorer :

C:\Windows\system32>netsh
netsh>winhttp
netsh winhttp>
netsh winhttp>set proxy proxy_server "<local>" (ex : set proxy 192.168.1.1:8080)

or import form internet explorer

netsh winhttp>import proxy source=ie

 

I hope this helps you :)



#6 RobT

RobT

    Advanced Member

  • Administrators
  • 237 posts

Posted 17 January 2017 - 09:58 PM

Hi all, I've  got Immunet to connect over a proxy by adding a system proxy via:

1) disabling IE enhanced security configuration:
2) In IE -> settings -> internet options -> connections->lan settings-> enable use a proxy server-> advanced -> enter your proxy ip's and ports.

3) From  an administrator command prompt, and add a windows system default proxy with:

netsh
winhttp
show proxy
import proxy source=ie
show proxy

4)Immunet will now connect through your proxy and display your proxy info on the settings page after connecting.

Note though that as of v 5.0.2.10302 clamAV  can't perform  ClamAV definition updates from behid a proxy.
Also note that if Immunet can connect directly to the cloud without going through the proxy it will always prefer to connect directly.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users