Jump to content


Photo

Immunet Won't Uninstall Completely

uninstall immunet fail

  • Please log in to reply
7 replies to this topic

#1 Daviddotjenkins

Daviddotjenkins

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 31 January 2017 - 11:39 PM

I have run into a problem.

 

After the clamAv bug filling my Hard Drive I decided to uninstall Immunet after having happily used it for many years.

 

I followed all the instructions and Immunet looked like it was unisnstalled, but it still has folders on the computer in C:\Program Files\Immunet that are running .dll application extensions and I cannot remove them.

 

Please advise me on how I can achieve this.

 

Anybody got advice?



#2 ritchie58

ritchie58

    Staff Member

  • Moderators
  • 1,973 posts
  • LocationOil City, Pa. U.S.A.

Posted 01 February 2017 - 12:38 AM

If you chose the option that you were going to reinstall Immunet again during the uninstall process that does leave behind a folder in the Program Files directory. A running .dll application from that folder after attempting to uninstall is a bit of a concern. In recent weeks several other users have reported uninstall problems with the newest build. I'm now starting to believe these are not just isolated incidents but rather a possible bug with the software. Here's a couple of things to check.
 

Open TaskManager (press Ctrl, Alt, Delete) and see if Immunet's main process is still running, that being sfc.exe. If it is try to kill it with TaskManager and then see if you can delete the Program Files folder. If that doesn't work try this CMD prompt. Open a cmd window (click on Start, type cmd in the Search bar and click on the cmd icon) and type exactly this: net stop immunetprotect    then press Enter. Then try to delete the folder again.
 

If you continue to have issues feel free to add another thread to this topic.
Regards, Ritchie...


* Immunet Global Forum Moderator *


#3 Daviddotjenkins

Daviddotjenkins

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 02 February 2017 - 02:57 AM

Hi Ritchie, Thank you for your response.

 

I checked for the sfc.exe in TaskManager and there is no sign of it running.

 

I also tried the net stop immunetprotect command  with no success.

(This service name is invalid)

 

It is the dcm and dut 'dll's that are still running somewhere.

 

Please could you recommend further steps.


Edited by Daviddotjenkins, 02 February 2017 - 02:59 AM.


#4 ritchie58

ritchie58

    Staff Member

  • Moderators
  • 1,973 posts
  • LocationOil City, Pa. U.S.A.

Posted 02 February 2017 - 04:57 AM

Mmm. No luck there huh? In the past when I discovered a file that refuses to be deleted after an uninstall doesn't go well I've used this free tool called Malwarebytes FileASSASSIN to complete the task. It can eradicate any locked file but not entire folders. Once you delete the files in question within the folder, the Program Files folder should be able to be normally deleted then. So give this a look! https://www.malwareb...m/fileassassin/

 

Here's a Youtube video that outlines how FileASSASSIN is used. The vid is a bit dated but the info is still relevant.
https://www.youtube....h?v=kiwbvwXx-JA
 

Cheers, Ritchie...


  • Daviddotjenkins likes this

* Immunet Global Forum Moderator *


#5 Daviddotjenkins

Daviddotjenkins

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 02 February 2017 - 05:03 PM

Hi Ritchie,

 

Thanks again for your advice but FileASSASSIN was unable to remove the files either.

 

Any other suggestions?

 

Thanks.



#6 ritchie58

ritchie58

    Staff Member

  • Moderators
  • 1,973 posts
  • LocationOil City, Pa. U.S.A.

Posted 03 February 2017 - 03:14 AM

Hi David, now I'm rather perplexed why FileASSASSIN didn't work! It's always worked as it should for me. Did you try both delete methods? Using the normal and the delete at reboot options?

There's another thing you could try with FileASSASSIN. First boot up in "Safe Mode" and then use FileASSASSIN. Try the delete at reboot method with FileASSASSIN and then do a restart. If that doesn't work I'm at a complete loss! I'll have to contact Support/Development for you to get them aware/involved in your ongoing issue.

Not a bad idea to also send Support an Email if the above method doesn't work too. Here's the URL: support @ immunet.com. Also mention you did start a forum Support (Issues & Defects) topic in your email.

Best wishes, Ritchie...


* Immunet Global Forum Moderator *


#7 Daviddotjenkins

Daviddotjenkins

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 08 February 2017 - 03:01 PM

Hi Ritchie,

 

Sorry for the slow response.

 

Safe mode plus delete at reboot worked!

The files were successfully deleted and I was then able to go and delete the folder as well.

 

Thank you so much for your help.



#8 ritchie58

ritchie58

    Staff Member

  • Moderators
  • 1,973 posts
  • LocationOil City, Pa. U.S.A.

Posted 09 February 2017 - 02:24 AM

Hello again David, glad to hear that the final method did work! I have contacted Support/Development regarding this uninstall/reinstall bug. So hopefully some time in the very near future this bug gets the attention it truly deserves!

 

Cheers, Ritchie...


* Immunet Global Forum Moderator *






Also tagged with one or more of these keywords: uninstall, immunet, fail

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users