Jump to content
Mop Closet IT

Immunet 6.0.8.10638 High Cpu Usage

Recommended Posts

Hello,

There are other post discussing this same issue but I created a new post because this is a different version then mentioned in other posts.

OS: Windows Server 2016 Ver. 1607 OS Build:14393.2430

CPU: Intel Xeon E3-1220v5   3.0Ghz

Ram: 16Gb DDR4 2666

Immunet Version 6.0.8.10638

"Cisco AMP for Endpoints Connector" is using 50%-90% CPU resources. Sometimes more. It does this even when the system is idle. After reading the other post I added Windows Defender to Immunet's exclusion list and added Immunet to Windows Defender's exclusion list. This seems to have helped some as the CPU usage is now  40%-80% (most of the time). Is this amount CPU usage normal?

Thanks,

Share this post


Link to post
Share on other sites
3 hours ago, Wookiee said:

We are aware of the issue and should be releasing a fix 'soon'

Just to report that having the same issue here install on Windows Server 2012R2. 
Try added whole C & D drive in protection exclusions cannot help. Hopefully new release will be very "soon" ?

Share this post


Link to post
Share on other sites

Disable the ClamAV engine for now- if not, it shouldn't make that much of a difference. To really fix it, a patch / new release will have to take place.

Share this post


Link to post
Share on other sites

HI there,

I am experiencing high cpu usage on 6.2 anywhere from 60-100% the file that is using all the CPU is sfc.exe
I have stop and restart the service then cpu usage will start heading up over a couple of days then I have to stop/restart.

Rinse and repeat.. It certainly drags the performance of our server down almost to a dead halt sometimes.
I have uninstalled and reinstalled, but no change.


Windows Server 2008 R2 Standard x64
Ram 48Gb
Dual Xeon E5620 2.4 gHz

Immunet 6.2.0.10768

Let me know if you need more info.

Cheers
Scott

Edited by scottv

Share this post


Link to post
Share on other sites

Are you using any third-party software applications that constantly or very frequently writes to disk Scott? That can sometimes increase Immunet's CPU cycles as it scans the files for any malicious content as they're being created and added to your drive.

Share this post


Link to post
Share on other sites
3 minutes ago, ritchie58 said:

Are you using any third-party software applications that constantly or very frequently writes to disk Scott? That can sometimes increase Immunet's CPU cycles as it scans the files for any malicious content as they're being created and added to your drive.

I have considered this possibility, we have a backup program that runs twice a day.
I have excluded the backup location (External Drive) from Immunet but also the high CPU usage happens at times when the backup is not running.
There are probably lots of files that get modified on a daily basis by our 7 users.. but I have observed the high CPU usage can occur
first thing in the morning when I am the only one in the building, therefore being the only user and at that point in time I am really only just observing task manager.

We have a large (almost 1 gb ) database - Postgress on this server but again the high CPU happens when no-one is using it.
I'll see what else might be doing lots of writes that I don't know about and get back to you.
Thanks for the quick reply.

Cheers
Scott

Share this post


Link to post
Share on other sites

Hi Scott, I was going to mention that O.S. backup/mirroring protocols can sometimes be the culprit. Excluding the final backup location was a good idea but you could implement an additional exclusion to see if that has any positive effect. Try excluding the "entire Program Files folder" of the backup software program in question. Worth a try I think.

Best wishes, Ritchie...

Share this post


Link to post
Share on other sites

One other thing Scott. If the CPU usage is still too high after excluding the Program Files folder you could try and disable "Monitor Program Start" & "Blocking Mode" in Settings if these are currently enabled. You'll loose a little bit of protection by disabling these settings but that could also help.

Regards, Ritchie...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×