Jump to content
sbs

Immunet 3.0 Fails To Create A Scheduled Scan

Recommended Posts

When creating a scheduled weekly scan on saturdays at 3am. Full scan only when logged on. The creation fails with "unknown error occurred".

 

As a consequence, I cannot create scheduled scans.

Share this post


Link to post
Share on other sites

When creating a scheduled weekly scan on saturdays at 3am. Full scan only when logged on. The creation fails with "unknown error occurred".

As a consequence, I cannot create scheduled scans.

Hi sbs,

First check, if your Taskscheduler in Windows is really working. If not working, consult Ritchie58, who had problem with Taskscheduler after a Windows Update, that got awry. For Windows 7 Taskscheduler is found here: C:\Windows\System32\tasksch.msc /s

If it works do in this order:

Step1: Immunet

Immunet -> Settings -> Scan Settings -> Sceduled Scan -> Add New Scheduled Scan

Set "every": week, day, or month, Set "on": Monday, Tuesday,.....,or Sunday, Set "at": 1,2,3,.......,or 12, Set AM or PM, Set "of":..........Click on "Browse" button to select drive or folder.

Click on "Create" to save the schedule

Then you will see , that your scheduled scan is listed above "Add New Scheduled Scan"

Step 2: Taskscheduler in Windows

Now you can edit this scheduled scan completely by going to C:\Windows\System32\tasksch.msc /s (Windows 7). Its shortcut icon is a white round clock showing time 3:00. When you have found this shortcut, click & open it. Look at the alphabetical list and you'll find your scheduled scan done in Immunet there. Right-click on Immunet999999 and select Properties from the curtain menu. You will find a window with many tabs about this particular schedule. (As I have a Swedish OS, it is a bit useless to explain every tab there, with its contents.) But you can really modify the schedule here: eg. decide if scan should be done at computer start, logon, when idle, every 2 hours etc.)

Cheers,

sweidre

Share this post


Link to post
Share on other sites

Hi,

 

my taskscheduler is working properly. Can you copy/paste in the forum the command line for starting a full scan? I'll schedule manually the task in the task manager.

Share this post


Link to post
Share on other sites

The creation fails with "unknown error occurred".

As a consequence, I cannot create scheduled scans.

Hi again sbs,

I have been out doing some gardening cleanup in the sunny springtime here, when I got some second thoughts, as usual!

Your expression: "unknown error occurred" I remember! It was mentioned in another thread in this forum, and I gave the same reply then. My reply was not wrong, but an admin/mod solved it easily in another way!

Who posted the topic, I do not remember! Who found the solution, I do not remember either! What I know is that the topic was placed after the Windows 7 SP1 was issued by Windows Update. (The Swedish version I installed 22 Feb 2011, so it must have been after that date, that Richie58 got his SP1 installed badly and his Taskmanager was destroyed! I will try to search for "unknown error occurred" using the search function in Immunet forum! If I do not return, I have not found that topic!

Cheers,

sweidre

Share this post


Link to post
Share on other sites

Hi, I have found a thread with this problem, but in fact I was looking for another one! For the time being study this thread:

http://forum.immunet.com/index.php?/topic/731-scheduled-scan/page__p__4014__hl__%2Bunknown+%2Berror+%2Boccurred__fromsearch__1&do=findComment&comment=4014

Cheers,

sweidre

Share this post


Link to post
Share on other sites

Hi,

my taskscheduler is working properly. Can you copy/paste in the forum the command line for starting a full scan? I'll schedule manually the task in the task manager.

Good to hear, that your Taskscheduler is working properly! That means, that your problem will be easily solved by somebody else in the forum! The command line for starting a full scan I do not know! I hope, that somebody else will help you about this!

Cheers,

sweidre

Share this post


Link to post
Share on other sites

When I first tried to create a schedule, I was prompted for credential, and could not get them to work. However, in the current version there is a checkbox that says "only run when logged" so taht it does not require entering credentials.

 

It fails anyway.

 

The user name is mylogin@myactivedirectory domain, but is greyed. Since it has been filled by immunet, one would expect that it is entered properly.

 

--

SBS

Share this post


Link to post
Share on other sites

When I first tried to create a schedule, I was prompted for credential, and could not get them to work. However, in the current version there is a checkbox that says "only run when logged" so taht it does not require entering credentials.

It fails anyway.

The user name is mylogin@myactivedirectory domain, but is greyed. Since it has been filled by immunet, one would expect that it is entered properly.

SBS

Hmm.. this sounds wrong!

1. The old way

For creation of a scheduled scan you should fill in the username & password, that you are using to login to your computer, not the credentials, that you use for logging in to the Immunet software or forum!

I doubt, that you are using this long username, when logging in to Windows:mylogin@myactivedirectory (Puh!)

2. New way

In the latest version 3.0.1.6112 a box has been added above with the text: "Run schedule only when logged in"

If the box is ticked, your username should be there (shaded). Password not needed!

 

Now, try the old way then:

A. Uncheck the box: "Run schedule only when logged in"

B. Fill in Username: (Note, the username you use when logging in to your computer)

C. Fill in Password: (Note, the password you use when logging in to your computer)

Cheers,

sweidre

Share this post


Link to post
Share on other sites

Hmm.. this sounds wrong!

1. The old way

For creation of a scheduled scan you should fill in the username & password, that you are using to login to your computer, not the credentials, that you use for logging in to the Immunet software or forum!

I doubt, that you are using this long username, when logging in to Windows:mylogin@myactivedirectory (Puh!)

2. New way

In the latest version 3.0.1.6112 a box has been added above with the text: "Run schedule only when logged in"

If the box is ticked, your username should be there (shaded). Password not needed!

 

Now, try the old way then:

A. Uncheck the box: "Run schedule only when logged in"

B. Fill in Username: (Note, the username you use when logging in to your computer)

C. Fill in Password: (Note, the password you use when logging in to your computer)

Cheers,

sweidre

 

1/ my apologies for not pointing out that my first try was before 3.0.1.6112

 

2/ I tried scheduling by entering a password, and it indeed works using the default user@ADDomain syntax for the user name (that définitively not the user I input for logging in) (I do know that internally that's my ADuser name and that windows matches the domain\user syntax to it)

 

3/ Unchecked the combo entered the password, rechecked : task creation works

 

4/ Tried to create a task without unchecking and entering the password : fails with unknown error

 

Looks to me like the password field is not optional (even when greyed)

 

--

SBS

Share this post


Link to post
Share on other sites

Interesting - I will look into this. I know we didn't test creating schedualed scans on computers joined to a domain. Is this an accurate description of the behavior your seeing:

 

1) When you leave the "Run scan only when logged in" box unticked, you see the username "mylogin@myactivedirectory" and creating the schedualed scan fails with the error "unknown error occurred"

 

2) When you tick the "Run scan only when logged in" box and enter your full "mylogin@myactivedirectory" domain name as your username, creating the schedualed scan also fails with the error "unknown error occurred"

 

Also, can you tell me if your domain user has a password or not?

 

 

 

As a manual workaround you can try creating a scedualed scan like this:

1) Open an elevated command prompt and run "net stop immunetprotect"

 

2) Open an elavated wordpad (not notepad), use it to open c:\program files\Immunet\Local.xml, and put this anywhere inside the tag:

 

20|1083312|Weekly Scan: "C:\" (Sunday at 3:00 AM)|3|4|C:\|48|0|2011|5|2|2013|5|2|3|0|0|0|1|2|1|1|2046|0|0

 

This will scan C:\ and all it's subdirectories - replace the C:\ with a different path if you want (don't forget the trailing backslash). Don't worry about changing the time here, it shoulden't matter.

 

3) Open task schedualer and create a new schedualed task to run the comand:

C:\Program Files\Immunet\ips.exe 13 1083312 0

You can schedual the task however you like - I don't think it has to match what appears in Immunet. Make sure to set the user & password.

 

4) Manually run your schedualed task and watch the Immunet interface to ensure your scan runs. You should see the "Scan" option change to "Scanning", and you should see a new event in the history when the scan completes.

Share this post


Link to post
Share on other sites

1/ my apologies for not pointing out that my first try was before 3.0.1.6112

2/ I tried scheduling by entering a password, and it indeed works using the default user@ADDomain syntax for the user name (that définitively not the user I input for logging in) (I do know that internally that's my ADuser name and that windows matches the domain\user syntax to it)

3/ Unchecked the combo entered the password, rechecked : task creation works

4/ Tried to create a task without unchecking and entering the password : fails with unknown error

 

Looks to me like the password field is not optional (even when greyed)

 

--

SBS

Hi SBS,

I have just tested the old way in my Immunet Free 3.0.1.6112:

A. I unchecked the box: "Run scan only when logged in" (The two greyed out fields turned into normal then)

B. Username: This field I filled in with my username, that I use when I login to Windows

C. Password: This field I filled in with my password, that I use when I login to Windows

and the scheduled scan was added as another scheuled scan above. So for me the old way works to 100%

For sure, you need qualified help by an admin (I hope RobT or Anthony will attend to this forum soon!)

Cheers,

sweidre

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...