Jump to content
chipo

Sometimes, Agent Does Not Connect To Internet

Recommended Posts

In last days, when Windows starts, Immunet´s agent sometimes does not connect to internet. I have KIS 2011 and I´ve allowed all outbound/inbound traffic for agent.exe in KIS firewall.

 

I must restart the Immunet service to get connected.

 

Is there a problem with Immunet servers?

 

Sorry for bad english

  • Like 1

Share this post


Link to post
Share on other sites
Guest OrlandoP

Check with the Task Manager (ctrl + shift + esc) if agent.exe and iptray.exe are running then run a CMD as Administrator,

 

Type:

 

net stop immunetprotect

wait...

net start immunet protect

 

Orlando

Share this post


Link to post
Share on other sites

Check with the Task Manager (ctrl + shift + esc) if agent.exe and iptray.exe are running then run a CMD as Administrator,

 

Type:

 

net stop immunetprotect

wait...

net start immunet protect

 

Orlando

 

Yes, both processes are always running. I have to go to Administrative Tools> Services and restart the Immunet service (sometimes, not always agent.exe appears offline)

Share this post


Link to post
Share on other sites

Please use the System Diagnostic Tool and send the file generated to support at immunet.com

 

Orlando

 

Agent.exe.log file shows several errors from agent.exe when connecting to the Internet.

 

File attached to this mail and also a screenshot of the firewall settings.

firewall%252520rules%2525201.JPG

firewall%252520rules%2525202.JPG

 

I have Norton DNS in my network settings

agent exe log.zip

Share this post


Link to post
Share on other sites

Is there any solution to my problem? Some days ago I sent an email to technical support, with the file created with diagnostic tool. Not answered. I´ve uninstalled and reinstalled Immunet. Sometimes still fails to connect to internet.

 

I had to create a bat file to restart the immunet service every time windows starts.

 

I do not think that is the solution to my problem.

Share this post


Link to post
Share on other sites

Is there any solution to my problem? Some days ago I sent an email to technical support, with the file created with diagnostic tool. Not answered. I´ve uninstalled and reinstalled Immunet. Sometimes still fails to connect to internet.

 

I had to create a bat file to restart the immunet service every time windows starts.

 

I do not think that is the solution to my problem.

 

Hello Chipo we are having difficulty finding the email from your Yahoo email with the Support Diagnostic File attached. Can you send the file again to support@immunet.com and we will check it out. Reference this forum post so we know whose issue we are dealing with.

 

Stephen

 

Immunet Employee

Share this post


Link to post
Share on other sites

Hello Chipo we are having difficulty finding the email from your Yahoo email with the Support Diagnostic File attached. Can you send the file again to support@immunet.com and we will check it out. Reference this forum post so we know whose issue we are dealing with.

 

Stephen

 

Immunet Employee

 

Hello Chipo, we received your Support Diagnostic File and we have sent you troubleshooting instructions. Even with your firewall setting changes we see all traffic is not reaching the cloud. Try out Immunet with the firewall disabled. This will help to eliminate or confirm the firewall as the cause.

 

Stephen

 

Sourcefire - Immunet Employee

Share this post


Link to post
Share on other sites

I´ve installed KIS 2012 today. I´ll see how it works with Immunet protect.

Hi chipo,

I have no experience of KIS firewall, but is it possible to teach KIS to accept clean files by giving KIS a certain time to be aquainted with important files in its environment?

Cheers, sweidre

Share this post


Link to post
Share on other sites

Hi chipo,

I have no experience of KIS firewall, but is it possible to teach KIS to accept clean files by giving KIS a certain time to be aquainted with important files in its environment?

Cheers, sweidre

 

Hi sweidre,

 

I did not understand what you've written. Kaspersky lets you to exclude programs and files from his control (exclusion list).

 

I´ve the Immunet folder, agent.exe and iptray.exe in Kaspersky exclusions too.

 

Greetings

Share this post


Link to post
Share on other sites

Hi sweidre,

I did not understand what you've written. Kaspersky lets you to exclude programs and files from his control (exclusion list). I´ve the Immunet folder, agent.exe and iptray.exe in Kaspersky exclusions too.

Hi chipo,

If Kaspersky has an exclusion list, it should be enough, in my mind. (ZoneAlarm & ESET Smart Security have both a learning mode to be used until all programs have been accepted by the firewalls, and then they can be switched into an automatic mode, but I cannot assess what method is preferable. Cheers, sweidre

Share this post


Link to post
Share on other sites

Hi chipo,

If Kaspersky has an exclusion list, it should be enough, in my mind. (ZoneAlarm & ESET Smart Security have both a learning mode to be used until all programs have been accepted by the firewalls, and then they can be switched into an automatic mode, but I cannot assess what method is preferable. Cheers, sweidre

 

Hi sweidre,

 

I understand you now. Kaspersky has an automatic mode too, but I´ve deactivated it, so Kis is in interactive mode.

 

Greetings

Share this post


Link to post
Share on other sites

Hi, I need a link to download Immunet Protect 3.0.3.6870. Latest version (3.0.4.7241) doesn´t work for me. It´s disconnecting from internet all the time, so I want to install an older version.

 

Thanks

Share this post


Link to post
Share on other sites

That may be a problem chipo because Immunet uses boot-strapper installers. That means that regardless of the version the installer will connect to the Immunet severs and download the newest version of Immunet. Sorry to hear you're still having problems with agent.exe. I hope the SourceFire/Immunet staff can come up with a solution for you. Best of luck, Ritchie...

Share this post


Link to post
Share on other sites

That may be a problem chipo because Immunet uses boot-strapper installers. That means that regardless of the version the installer will connect to the Immunet severs and download the newest version of Immunet. Sorry to hear you're still having problems with agent.exe. I hope the SourceFire/Immunet staff can come up with a solution for you. Best of luck, Ritchie...

 

Thank you very much. From what I see, my only option is to uninstall Immunet protect and wait for a new version.

Share this post


Link to post
Share on other sites

Nobody has the offline installer for version 3.0.3.6870? (when you run Immunet setup, it downloads the full installer)

 

Last version of Immunet Protect doesn´t work well to me. If I can´t get an older version I must uninstall it, because the scaner doesn´t work.

Share this post


Link to post
Share on other sites

Hi,

 

Hope you don't mind me jumping in on this agent.exe discussion as I'm having problems with agent.exe consuming huge amounts of CPU at the moment. Currently it's running at 50% but before that and before a forced reboot it was running at 98%. Needless to say my system is now constantly freezing. Am running XP SP3 and with KIS 2012 installed and am running the current version of Immunet Protect 3.0.4.7241.

 

Have tried ending agent.exe and iptray.exe processes in the Task Manager but TM will not allow me to end the processes.

 

Cheers,

John

Share this post


Link to post
Share on other sites

Finally, after nearly a month with this problem, I uninstalled Immunet Protect. I don't want a program that is not working for me. Thanks for nothing.

Share this post


Link to post
Share on other sites

Finally, after nearly a month with this problem, I uninstalled Immunet Protect. I don't want a program that is not working for me. Thanks for nothing.

Hi chipo,

It is a pity, that you have prematurely uninstaled Immunet Protect during a weekend! You should have waited with that decision until a workday, when Immunet staff is more frequently visiting this forum! Cheers, sweidre

Share this post


Link to post
Share on other sites

Hi sweidre, I've been waiting for almost a month for a solution. In recent days I have been asking for an earlier version, but nobody could give me a link. Agente.exe is disconnecting from internet constantly. As you understand, if Immunet doesn't work, I don't want it installed.

 

Greetings

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...