Jump to content
geos_one

Silent Install & Uninstall & Passing Serial To Install

Recommended Posts

We are trying to integrate the immunetprotect as a opsi package

But we came across a big problem of the uninstall.exe:

 

The Uninstall.exe is spawning a process and exits

witch results in a problem with the install directly running after the uninstall

the install exits with "product already installed" because the uninstall hasn't finshed yet

because the opsi system checks if the the uninstall program is still running and waits

 

the second issue is:

How can we add the serial n.r. to the silent install

commandline switch to the installer exe or

is there a xml token to modify in local.xml

 

here the link to the immunet opsi package sources

http://git.disconnected-by-peer.at/go-opsi/immunet/

 

thx for your help in av

Mario

Share this post


Link to post
Share on other sites

as you can see here the uninstall.exe is started and is done 1sec later

 

[5] [20.02.2012 08:53:09] Execution of Winbatch_uninstall_32

[6] [20.02.2012 08:53:09] Call ""C:\Programme\Immunet\3.0.5\uninstall.exe" /S"

[6] [20.02.2012 08:53:09] Waiting until the called process is finished

[6] [20.02.2012 08:53:10] ExitCode 0 Executed process ""C:\Programme\Immunet\3.0.5\uninstall.exe" /S"

[6] [20.02.2012 08:53:10]

[6] [20.02.2012 08:53:10] ~~~~~~~ Start Sub ~~~~~~~ sub_check_exitcode

[5] [20.02.2012 08:53:10] comment: Test for installation success via exit code

 

and a litte later in the log

the install is not possibel because its still not uninstalled

 

[5] [20.02.2012 08:53:11] Execution of Winbatch_install_32

[6] [20.02.2012 08:53:11] Call ""P:\immunet\X86\protect-en-us-3.0.5.7688-32-tcp.exe" /S"

[6] [20.02.2012 08:53:11] Waiting until the called process is finished

[6] [20.02.2012 08:53:13] ExitCode 1638 Executed process ""P:\immunet\X86\protect-en-us-3.0.5.7688-32-tcp.exe" /S"

[6] [20.02.2012 08:53:13]

[6] [20.02.2012 08:53:13] ~~~~~~~ Start Sub ~~~~~~~ Sub_check_exitcode

[5] [20.02.2012 08:53:13] comment: Test for installation success via exit code

[5] [20.02.2012 08:53:13]

[5] [20.02.2012 08:53:13] Set $ExitCode$ = getLastExitCode

[6] [20.02.2012 08:53:13] The value of the variable "$ExitCode$" is now: "1638"

Share this post


Link to post
Share on other sites

Mario,

There is no way to pass the serial number to the install. You could write it to the local.xml since you're already in there modifying that. The xpath will be config/agent/license/key. As for the uninstall, you should look at %TEMP%\immpro_install.log, but 1638 means:

 

Another version of this product is already installed. Installation of this version cannot continue. To configure or remove the existing version of this product, use Add/Remove Programs on the Control Panel.

 

Did you reboot after the uninstall? During uninstall, we can only mark things like filter drivers for undelete, so you have to wait for reboot.

 

I hope that helps,

--Millard

Share this post


Link to post
Share on other sites

I hope that helps,

--Millard

yes it helped and now i am shure the silent uninstall is not working with opsi

i had to create a autoit script that is doing a normal uninstall with gui

 

http://jira.disconnected-by-peer.at/browse/GOPSI-31

 

thx for your help

Mario

 

p.s. now add license key setting and get rid of all the devel dos boxes in the package

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...