Jump to content

Immunet 3.0.6 Beta Available


Recommended Posts

Hi everyone, the Immunet Public Beta is now available! The installer below can be used for new installations and upgrades from all prior 2.x.x and 3.0.x versions:




Please note this beta will require a full uninstalled before re-installing with an official Immunet release version.


What's new for 3.0.6 Beta 1:


* Enhanced virus protection based on signed file information

* Enhanced virus protection based on parent file execution

* Performance enhancements based on enhanced caching of Immunet's databases

* Fix for the ampersand (&) character breaking exclusions

* Fix for very long exclusion paths sometimes crashing the Immunet interface

* Fix when excluding an entire drive from scanning (e.g. "e:\")


FYI, we are also planning on releasing a Beta 2 that will add support for Immunet on Windows Server 2003!


Reporting Issues:

If you have any feedback please post it to this thread. If you think you've found a bug please include a description of the problem, instructions to reproduce it, and any relevant screenshots.

Link to comment
Share on other sites

Excellent news! Is there an estimated release date available as to when they anticipate going final?


Also, do the developers plan on sticking with version 3 for a while and is there a roadmap as to when Immunet will move to a version 4? I realize I may be jumping the gun here!! It's just that the blog has not been updated since May 2011 and I was beginning to get concerned.

Link to comment
Share on other sites

New version yields the same problem that has existed for many moons! Continued disk hashing after running the initial required flash scan? I don't how long the hashing continues...but requires a reboot to calm the disk drive down. Also if the initial scan is stopped prematurely it satisfies the requirement even though it never completed. Win XP Pro SP3..running concurrently with Panda Cloud AV.


Link to comment
Share on other sites

Sorry to hear your still having the same problems Davey. You know that no matter how hard a software developer tries, it's almost impossible to take into account every conceivable system configuration that a person might have. I have never had a problem with the disk I/O hashing. Then again perhaps my configuration has enough system performance that it is a non issue for me. I have a custom built machine and use SATA 2 10,000 RPM hard drives so maybe that has something to do with it. Regards, Ritchie...

Link to comment
Share on other sites

Hi Davey, we usually see some disk hashing after a flash scan completes however it's generally pretty low and usually lasts in the low 10s of seconds on a computer with modest specs (or ~30 seconds, maximum, on a slower computer). The hashing is worse on full scans - lasting between 4 to 8 minutes depending on how many files were scanned and how complex your folder tree is. FYI, we made a 50% improvement on this in 3.0.5 (3.0.4 was taking 8 to 16 minutes), and are still working on it - there are actually minor improvments for 3.0.6, however I don't have any real performance data here yet.


So, a few quick questions that will help me figure out exactly what is causing your hash issues during flash scans:

- did add exclusions to Panda for Immunet, and to Immunet for Panda?

- Can you tell me how many files the flash scan says it has scanned when it finishes?

- How much free space do you have left on your c drive?

- Do you know how fast your c drive is? I.e. laptop/5400RPM/7200RPM/10K RPM/flash?

Link to comment
Share on other sites

Thanks for fixing the ampersand issue!


Quick finds for this beta:

- The "Notices" window is empty/has no info.

- With an update over the old Immunet, the Plus advertisement remains. But with a fresh install there is no Plus advertisement.

- After a contextmenu scan, the "Elapsed time" still zeroes out.


Yours sincerely,

Jochem Jean.

Link to comment
Share on other sites

Thanks for the feedback Jochem!


-We're working on a fix for the Notices window now. We think we can fix this server side so it should just start working in the next couple days.

-Plus advertisements missing in new installs will be fixed by the end of the day.

-Context menu scan issue has been bugged (good catch!). The fix for this probably won't make it into 3.0.6.

Link to comment
Share on other sites

  • 2 weeks later...

I encountered a minor glitch today. When Immunet loaded the Update Now section of the UI was yellow and stating Never Updated. I tried to run the Updater and nothing would happen. Nothing downloaded. So I clicked on Hide Tray Icon, and then relaunched the System Tray Icon with the Desktop Icon. That seemed to do the trick. After that the Update Now information was correct and I was able to download the current updates. agent.exe must have failed to load properly during boot-up. This is the first time this has happened with this beta version.

Link to comment
Share on other sites

Hi popularboy23, the process that controls the GUI is iptray.exe. Make sure that your firewall or other security software is not blocking this process. Another process that Immunet uses, which is agent.exe, needs internet access as well. That would be the first thing to check. Regards, Ritchie...

Link to comment
Share on other sites

  • 3 weeks later...

Hi Developers, thanks for the chance to test the 3.0.6.

Couple of observations.

Installed on a Media Center 2002 with SP3 applied. The install was done over 3.0.5 Pus. The installation proceeded as expected shutting down the Immunet Service, but toward the end it said that it could not continue until the PC was rebooted. On the reboot the installation did NOT restart and I also received a message that stated that the Immunet Protection.dll (or something like that) file could not be found so the services were not started. The Agent was not loaded and the IPTray wasn't loaded. So I restarted the install and everything seemed to proceed and end with a request to reboot the PC to complete the installation. After this second restart, IPTray and Agent started, but when opening the IPTray I could see the Computer wasn't secure because no scan had been done, I expected this was a new version. I started a Flash Scan which completed, but then the disk started thrashing and didn't end for over ten minutes, so I shutdown and restarted the computer. I know this problem is already documented, but thought I should let you know it is happening on this platform.

I tried a Rootkit scan and while the scan timer says it is proceeding there is no disk activity and the "Files Scanned" remains at zero.

I also notice that the Lasted Scanned time is ahead by 60 minutes from my actual computer time.

The Notices screen is as expected with the latest versions announcements.

Hope this helps the developers. Thanks for continuing to develop. I'll continue to test and post results.

Link to comment
Share on other sites

It sounds like one or more files may have been missing or corrupted during the first installation attempt. Did you have any other anti-virus/anti-malware/anti-spyware or behavior blocker programs running at the time? You are correct about the time stamp not displaying the correct local time bvamunds. It is ahead by one hour. No adjustment made during the Daylight Savings Time change perhaps? Great observation! I never noticed that myself. As far as the TETRA module (which handles the root-kit scans) I would recommend to go into Settings and double check that the TETRA module is enabled. If it is enabled perhaps RobT might want you to send in an SDT report regarding the issue.

Link to comment
Share on other sites

Good morning Ritchie.

During the upgrade to 3.0.6 Beta no other anit-malware, anti-virus, or anti-spyware was running. I think what happened is that the file was deleted in the upgrade process and the registry key or startup record to start IPTray was still present, but it couldn't start because the file was already removed.


I checked the Tetra Settings this morning and both Enable Tetra Engine and Allow Definition Updates are ON. See my notes below as I was doing more testing this morning.


This morning I ran some more test on the 3.0.6 Beta product. Firefox 12.0 was also running during these tests. I noticed that if I watch the Windows Task Manager memory usage for agent.exe and iptray.exe that their total is greater than the total showing in 3.0.6 Beta IPTray window. It is off by about 1.5 to 2 megs consistently. Don't know if this is situation with 3.0.5 since it is uninstalled.


Also Noted that Under Setting for the IPTray that the PROXY Setup window doesn't exist like it use to in the 3.0.5 version. Not sure if that is an intended change because you are automatically detecting now?


If I run a Custom Scan and during the scan hit the Pause button, the scan does pause, but the Elapsed Time continues to count. Not sure if this is feature or if Elapsed time should be paused also.

If I run a Full Scan, the scanning starts but it takes about 15 seconds before the Files Scanned starts to increment files actually scanned. Again the Elapsed time continues to count even if I Pause the scan.

If I run a Rootkit scan, from disk activity it appears a scan is executing, Elapsed Time is incrementing and Scanning shows C:\ but Files Scanned is not incremented. Clicking on Pause did not seem to affect disk activity. I allowed RootKit scan to run for 12 minutes Elapsed Time showing with disk activity but no changes to Files Scanned counter or the Scanning file record change from C:\.

History does not report the above scans were started and aborted either. It would be nice if these aborted scans were included in the File History information.

If I check the Agent.exe log in the 3.0.6 folder that there are a lot of ERROR messages being written during the scans about UNABLE TO OPEN DIRECTORY and UNABLE TO OPEN HANDLE. I'll send another SDT with that information for you to look at.


I was looking at the SDT from yesterday and noted that when I installed 3.0.6 Beta that the C:/Program Files/Immunet folder still has a 3.0.5 with subfolders. Will the final 3.0.6 keep the 3.0.5 essentials making a 3.0.5 folder a requirement?


I also notice that BitDefender Threat Service is now running under Computer Services. I didn't install this so did some investigation. I stopped the service and it stays stopped except if I attempt to run a ROOTKIT SCAN when it self starts. This is what is keeping the Rootkit scan from running because it throws an error message about missing dll's in the Windows Event View log for Application event "scan". OK so I'm the curious type. I opened my Registry and sure-enough BitDefender was added by Immunet. The error message is:

The description for Event ID ( 0 ) in Source ( scan ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: Service started.


I checked the registry changes made by the Immunet 3.0.6 beta installer for system pointers. InproServer32 is pointing to HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{6DFC0DC7-FDC5-44C2-8B80-5977BA8F8ACC}\InprocServer32\\(default)c:\Program File\Immunet\tetra\scan.dll and the file does exist in the folder, which I also checked. There is cleanup to do in the file names, service names and registry adds if BitDefender Threat Service is going to be used for the Rootkit scan, to correctly identify as Immunet instead. I was running the PC with Administrator privileges so there should not be a security issue that is preventing the file from running. Hope this is helping you with the Beta test.


Well, I hope this helps the developers.

Link to comment
Share on other sites

Hi bvamunds, thanks for your bug report! I'm going to try and find a copy of this OS to reproduce that issue. In the mean time, can you please check your computer and see if you can find Immunet's install logs? They should be in:

C:\Documents and Settings\Administrator\Local Settings\Temp\immpro_install.log


C:\Documents and Settings\Administrator\Local Settings\Temp\immpro_runtime.log

If you find them please email them to support@immunet.com with the subject: "For RobT: mc2k2.sp3 install logs" and I'll get a developer on this right away.


I think at least some of the other other issues you reported are based on the install error you're seeing - by the sounds of it a driver is not installing correctly which causes your Flash & Rootkit scans to fail/stay at zero.


The Lasted Scanned time being ahead by 60 minutes is a time zone bug. In you email above, can you please let me know what your timezone settings are?

1) right click on the clock in your system tray and select "Adjust Date/Time"

2) click on the time zone tab and tell me what timezone you're in, and if you have "Automatically adjust clock for daylight savings changes" checked?

Link to comment
Share on other sites

Hi Ritchie,

I found the immpro_install file, but there wasn't a immpro_runtime file in the same directory. There is an "is-4MUL2.tmp" folder but it is empty. I'll send via seperate email to your attention.


As for the timezone issue. I'm set to Central Time with "Automatically adjust clock for daylight saving changes" checked.


Hope this is helping your developers. Best Regards, Brian A

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...