Jump to content

Unable To Scan, No Agent.exe

Recommended Posts

Hello everybody,



I"m having problems with immunet, it is unable to connect to the internet and as a result i cant scan at all. I was able to update the program though

what i have found out / done:


- Agent.exe cant be found in task manager

- Agent.exe wont start when trying to launch it from the program files folder

- An agent.exe note pad file can be found filled with stuf like:


(180555, +0 ms) Dec 28 21:22:22 [5732]: ERROR: CDBBase::Execute NFMUrlFileMapDB: table nfm_url_file_map already exists

(1352247, +4040 ms) Dec 28 21:41:54 [4036]: ERROR: History::Prepare: sqlite3_prepare_v2 INSERT INTO history (id, type, file, filename, source, sourcename, created_at, disposition, flags, detection, loc) values (0, 1, "e22782e158b1dfb0452fb69c5582e17c1f0668c6e7d3d00364008c6dbde63b5f", "\\?\C:\Users\Enzo\AppData\Roaming\Corsair\tempmap.dat", "dec452941631bfb35f6789049ccb2a50ea1b50dbec3e0a1fb7a20f63587659cd", "\\?\C:\Program Files (x86)\Corsair\Corsair Link\CorsairLINK_HardwareMonitor.exe", datetime('now'), 1, 0, "", ""); : 2 : The system cannot find the file specified.

(1352310, +63 ms) Dec 28 21:41:54 [2956]: ERROR: Event::HandleExecution[2956]: look up of processname: \\?\C:\Windows\system32\DllHost.exe failed

(1352481, +171 ms) Dec 28 21:41:54 [5784]: ERROR: Event::HandleExecution[5784]: look up of processname: \\?\C:\Windows\system32\NOTEPAD.EXE failed


just a giant list full with these kinds of Error's


-I tried a full reinstal of immunet ,

-i tried CMD with the stop and start from immunetprocect.


I dont know what els to do :(


Edit: " please remove this topic because of my own stupidy, i didnt realise that the topic just below was simular to my own problem, Where they advised the reinstal. I did try reinstalling. Out of habbit i pressed yes on the very last question without reading it fully ( thinking it would delete all other junk) hehe sorry! Did a new reinstal with pressing no on the last question. problem fixed now :D

Link to comment
Share on other sites

Hi hemigidius, that's just what I was going to suggest too. That you review that FAQ topic. Choosing NO during the uninstall process does indeed delete all those old history files. Development is looking into ways to make these history files more resilient to outside infulences. It will be nice when this bug is finally fixed. Glad things worked out for though.


Cheers, Ritchie...

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...