Jump to content

Immunet does not keep track of any history

Recommended Posts

Hi Immunet team,

My Immunet has been able to quarantine and identify threats, as well as run full scans on my system. Yesterday I ran a full scan and had 14 threats quarantined. However, my UI says the last scan was performed never and looking at any of the history tabs brings up an error claiming that I have "No data found for this criteria!". I want to permanently delete all my quarantined files, but I cannot view them using the UI. Please help.

Link to comment
Share on other sites

  • 2 weeks later...

Cisco doesn't seem to provide any support for Immunet, or have much of a presence on this forum anymore. Support used to be provided by an unpaid, under-valued volunteer, and he used to do a brilliant job, but he hasn't been active on here for a good while. Additionally, many bugs in Immunet (including this one) have gone unfixed for many years, therefore please use Immunet with caution and, whilst it is still updated occasionally, consider it unsupported. Keep adequate backups and don't rely on Immunet as sole protection.

If you open Immunet's main window (desktop icon, start-menu icon, or doubleclick the system-tray icon), and look just below the "History" option, you'll see a "Quarantine" option. If you click that, it should bring up another window, which will show all the files that Immunet has attempted to quarantine (some may already say "restored", some may say "quarantine failed", etc.). From here you can click on each file individually and press the "restore" or "delete" button as necessary. As far as I know, there is no option to batch-restore or batch-delete, but for just 14 files, this should not be too arduous. If it says "no data found for this criteria", Immunet doesn't have any record of quarantined files (possibly due to history corruption). If the same error message appears when you click on "History" rather than "Quarantine" in the main window, then I'd strongly suggest Immunet's internal history databases are corrupt.

The "Scan performed: Never" can often be cured by performing a flash scan, which takes a minute or two to do. If this occurs frequently, this is further evidence that Immunet's history files are corrupt.

If a restart of the computer doesn't fix either issue, then you can try a clean reinstall of Immunet. First, completely uninstall Immunet. When prompted to retain settings etc., make sure you don't retain the settings. I can't rememember if the installer phrases it as "do you want to keep Immunet's history and settings?" (in which case, click "no"), or if the installer phrases it as "do you want to also delete Immunet's history and settings?" (in which case, click "yes"). After Immunet has uninstalled, reboot the computer. Then reinstall Immunet. An update followed by a flash scan should make everything work properly again.

  • Like 1
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...