Jump to content

Full Scan Fails/stops After A Few Minutes

Recommended Posts

Hi, I've been using happily Immunet 3 alongside Norton Security Suite for almost a year without problems in Windows 8.1 but since yesterday I can't get it to perform a Full Scan:


I am using latest Immunet 3 on Windows 8.1 Pro and have problems now with Immunet Full Scans. I tried to do several Full Scans but they never complete since they always stop after a few minutes and there's is no entry in the history about a Full Scan attempt (see screenshot telling 0 files scanned). I noticed that the service ImmunetProtect always stops a few minutes into a full scan and hence the Full Scan never truly finishes. Yet, as for now, ImmunetProtect service restarts after about 5 minutes after a failed Full Scan.


I added Immunet 3 program folders to the Norton exclusion list (see pictures below). I also allowed it through the firewall (controlled by Norton). Yet, none of those measures helped.


Thanks for any help!









Folders excluded in Norton Security Suite:






Out of Topic: Will Immunet 3 be compatible with Windows 10?



Link to comment
Share on other sites

Hi FoxFerox, some people have reported problems using Immunet with Windows 8.1. Other folks seem to have no problem at all with this OS. Since you were one of the users that Immunet seemed to be functioning properly with 8.1 I would venture to guess you may have one or more files associated with Immunet that have become corrupted. I would suggest you try a complete unistall using Immunet's built in uninstaller. When asked by the uninstaller if you plan to reinstall Immunet click "NO" and then proceed with the remainder of the uninstall process. This will give you a completely clean unistall. Then just reinstall again. You will have to reconfigure the Settings you were using and also add what ever Exclusions you had. Actually, "it's not a bad idea at all" if you add an exclusion for Norton's Program Files folder to Immunet. Do the same for Immunet's Program Files folder with Norton's exclusion, exception list as well. That way there's much less of a chance of a conflict occuring between the two AV programs.


I posted a topic about the pending roll-out of Windows 10 if you care to read it. http://forum.immunet.com/index.php?/topic/2681-immunet-support-for-the-upcoming-windows-10/

Let us know if the reinstall fixed the issues or not.
Cheers, Ritchie...

Link to comment
Share on other sites

Thanks for your swift reply! I followed your instructions and used Immunet's built-in uninstaller. I reinstalled Immunet and it looks like the problem is solved. Even better, Immunet updates by itself. It never did that before. I always had to manually update virus database. So, Immunet works better than ever. I hope it stays this way. Please, could you leave this topic open for a couple of days in case the same issue or similar ones arise (I am a pragmatic pessimist <_<) so I can tell about it here.



Besides, very insightful topic you wrote about the next Windows release. In case there's a beta version of Immunet  for Windows 10, I would be the first to sign up. I really hope there will be Windows 10 support.


In the meantime, I will recommend Immunet to my friends and colleagues  :).

Link to comment
Share on other sites

Aargh, just when I thought all is running smoothly I got again the same problem: Immunet's Full Scan suddenly stops before completing. I checked the event viewer and saw again this message: "The Immunet 3 service is marked as an interactive service. However, the system is configured to not allow interactive services. This service may not function properly." I had no luck solving this before. I googled a whole day trying to find a fix. I copied and pasted below the event viewer's output about this problem further below. I hope this info serves to maybe solve that problem.






Event Viewer Output:

- System

- Provider

[ Name] Service Control Manager
[ Guid] {555908d1-a6d7-4695-8e1e-26931d2012f4}
[ EventSourceName] Service Control Manager

- EventID 7030

[ Qualifiers] 49152

Version 0

Level 2

Task 0

Opcode 0

Keywords 0x8080000000000000

- TimeCreated

[ SystemTime] 2015-06-25T01:23:00.502961400Z

EventRecordID 22261336


- Execution

[ ProcessID] 664
[ ThreadID] 7300

Channel System

Computer Toni-PC


- EventData

param1 Immunet 3

Link to comment
Share on other sites

Darn! I was hoping that would do the trick. I did think of something else though. Immunet does not support Fast User Switching. If you change user accounts (as in going from the Administrator account to a guest account for instance) you must then do a restart.


There is another option you can use to troubleshoot software problems yourself with Windows 8.1 called a Clean Boot. This link will take you to a Microsoft Knowledge Base article regarding this. https://support.microsoft.com/en-us/kb/929135

Link to comment
Share on other sites

Glad to hear that FoxFerox! That is weird though. Something is/was intermittently interfering with Immunet's main process, sfc.exe, for that type of behavior to occur. You say Norton is also your firewall. That would be something to double check. Make sure Norton's firewall isn't interfering with, limiting access rights or trying to sandbox one or both of Immunet's processes, the other being iptray.exe.

Regards, Ritchie...

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...