Jump to content

Service Stuck At Starting After Win Upgrade


Recommended Posts



Just wanted to report a possible incompatibility defect after upgrading my Windows 10 Pro to the latest Fall Creators Update (Version:1709 Build:16299.19).


After the upgrade, Immunet Windows service seems to be always stuck at "Starting" and "Scan Now" button is greyed out in the UI. I have replicated this issue on two of my installs at home, one running on bare metal and the other one running under Hyper-V.


Some further observations:

1- I tried uninstalling Immunet, however, it fails with "Failed to stop Immunet service, cannot proceed with the uninstall"

2- I was able to uninstall in Safe mode (I chose "not planning to re-install" option to make sure all existing config is removed)

3- I re-installed the latest Immunet with a fresh downloader from the website, restarted Windows and observed that the problem is back.


I am also surprised that the UI is not displaying any notifications for the failed service start. If I don't actually open the UI and see that the "Scan now" button is greyed out or actually go to service manager and see that the service is stuck, I would have never known that I am not getting the protection I thought I was getting. This can lead to a false sense of security as I am pretty sure background scans are not occurring right now either. Maybe a pop-up after a minute of inability to activate a service would be a good option?


Please let me know if you require any further info.






Link to comment
Share on other sites

Hi folks, I did have the first two users who reported this contact an Admin. via email but with the number of users reporting the same thing I'm going to contact an additional Admin. to see if I can get the examination of this issue expedited by the Immunet Development team!


Cheers, Ritchie...

Link to comment
Share on other sites

Please add me to the list of users that found this forum, hoping that it is simply the presence of Immunet on my computer that is causing the constant rebooting. I did run the Update Troubleshooter and an error that I found was that it could not start Windows to install the update.  Another thread I found on Microsoft suggests pausing or even uninstalling A/V software long enough to get the install through.


I can't find the Immunet Removal Tool to try this solution.  Can you point me in that direction so I can test the hypothesis?


Thanks for the help.

Link to comment
Share on other sites

Hello Plainswomen, if you're having difficulties uninstalling Immunet conventionally to check your hypothesis may I suggest you use Revo Uninstaller in Safe Mode.


The free version will work with 32bit systems adequately but if your system is 64bit use the fully functional free trial of the Pro version as that better supports 64bit systems. https://www.revouninstaller.com/revo_uninstaller_free_download.html


If you're not familiar with using Revo Uninstaller there are a number of good tutorial videos on Youtube you can check out. Just type in Revo Uninstaller in Youtube's search bar.

Link to comment
Share on other sites

Hi Everyone, 


I've had a few people reach out to me directly about this issue. Thank you! This is now a known issue that I've passed along to our research team this week. As soon as I have an update on the resolution time, I'll provide it here. 


Please continue to leave your comments. I'll check this forum daily so I can pass along as many details as possible. 


Best Wishes! 


Link to comment
Share on other sites

I came across the same exact issue today.

During Windows 10 update, I also received 3 notifications of quarantines (all false positives) tied to user32.dll for AMD (though I have an Intel system so I just removed the quarantined items before allowing Windows to finish updating) - I'm not sure if the quarantines were related to this issue, I sent Immunet support an email of those details.



I went into safe mode to uninstall fully. Re-installed. Install had no issues. But on restart, same stuck at "Starting...". Clearly there is an incompatibility with the latest Windows 10 Creators Update 1709.

I will have to uninstall Immunet again in safe mode and turn on Windows Defender (not very useful).  I have Malwarebytes running as well but need a reliable real-time scanning (Avast is no longer an option and AVG is a joke).

Link to comment
Share on other sites

Hello everyone, I was informed that the Immunet development team is hard at work with this issue. However with other pressing issues also being worked on at this time it could be a while before this Win 10 upgrade bug comes to a final satisfactory resolution.

The development team is also looking into a possible work-around in the interim.

Sorry for the inconvenience this is causing and I wish I had better news for you all but that's the way things stand at the moment.


Best wishes, Ritchie...

Link to comment
Share on other sites



Windows 10 Pro [64 bit], version 1709, build 16299.19.

When checking for updates, Fix It! responds with "Immunet is Up to Date", but Immunet still shows 18 Oct as last update.
I'm unable to scan because the Scan Now button is ghosted.

From the services desktop app, attempting to start, restart, resume, pause, or stop the service produces no visible response from computer.  (These are all ghosted.)

Windows Defender appears to be working OK, however.

Unable to uninstall Immunet because the uninstaller says that it was unable to stop service.  Had to go into Safe mode to complete the uninstallation.  I did NOT try reinstalling due to other user comments above.


As a contrast, on one of my other machines running Windows 10 Pro [64 bit], version 1607, build 14393.1770, Immunet appears to be functioning correctly.

Link to comment
Share on other sites

Hi all, I have some good news and some bad news. The good news is that the Immunet team will continue to work on this compatibility problem with Win 10 until a fix is found no matter the time or resources it takes!


The bad news is that they are recommending that any Win 10 user that encounters issues uninstall Immunet for now until a new build is rolled out.


More info can be found at this topic in the Announcements section. http://support.immunet.com/index.php?/topic/3418-immunet-606-windows-10-compatibility/


The development team is asking everyone who encounters this Issue with Win 10 to "please submit a Support Diagnostic Tool Report to support@immunet.com for analysis before uninstalling" if you haven't done so already. This could help to speed up a new build being released. More info on how to create & submit a SDT report can be found at this FAQ topic. The info is a bit dated but still relevant. http://support.immunet.com/index.php?/topic/1672-how-do-i-submit-a-support-diagnostic-tool-report/


Some email providers may mistakenly recognize the support dump attachment as possibly malicious and not up-load the file. To get around that you may have to first encrypt the 7zip file with a password. This will make it easier to up-load it as an attachment to the email if you run into that situation. Just don't forget to include the password in your email!


Not sure how to encrypt the file? Here is a helpful link from howtogeek.com. https://www.howtogeek.com/203590/how-to-create-secure-encrypted-zip-or-7z-archives-on-any-operating-system/

Link to comment
Share on other sites

Revo uninstaller wasn't working, so I did the following.  Takes 15 seconds and then you can just remove Immunet via the standard "Add or Remove Programs" method.


Launch the command window:

* open the start menu

* type "cmd" (without quotes)

* right click on "Command Prompt" and choose "Run as administrator"

* on the command line, type "sc delete ImmunetProtect_6.0.6"


It will confirm that service was successfully completed and you can now go remove it as normal.  Of course...now I have nothing protecting my systems...so, yeah, that's a problem.



Link to comment
Share on other sites


Just upgrade my PC to Win10 Fall Creators.

Checking Immunet for a scan I have the same problem as reported here.


I tried to uninstall Immunet :

- with Win10 uninstall process : result is FAILURE

- with  Revo Uninstaller Pro : result is FAILURE

- with the "cmd" as described above : result is SERVICE STOPPED than I uninstalled Immunet with Win10 uninstall process. 


Now waiting for a new version of Immunet.


Please help solve this issue.

Link to comment
Share on other sites

  • 4 weeks later...
  • 3 weeks later...


This topic is now archived and is closed to further replies.

  • Create New...