Jump to content

False Positive From Roblox Install?


Recommended Posts

My kids play Roblox and I'm trying to install the new update.  The  *.tmp install files are being flagged.  I can't figure out how to get around it and let the install continue.  roblox.com


This is the notice I receive:


Threat Quarantined


RBX-A9AFA437.tmp has been detected as W32.F38C6752B4-95.SBX.TG.  Quarantine was successful.




Then the installer locks in wait mode.  The RBX-*.tmp are the temp files for the install.  The name changes with each install.


I tried allowing the *.tmp extension but that did not work (I removed tmp as an allowable extension after I tried it)


I tried typing the file name in as an allowable, but the string changes with each attempt.


I turned on Game Mode... trying anything.  I've been working on it for three days


Any advice?



Link to comment
Share on other sites

It would be extremely difficult, if not impossible to white-list a temp file like that.

Did you try using a temporary generic Exclusion? As an example: If the file path for the temp file is C:\Users\ Ritchie\temp   then use an Exclusion for C:\Users\Ritchie ONLY?


If that doesn't work another option would be to kill Immunet before attempting to install the update. You can use TaskManager for this. Open TaskManager (press the Ctrl, Alt, Delete keys at the same time) and follow these instructions in this order.

Cick on the Services tab -> find the Immunetprotect_6.0.8 Service from the list -> right-click on the Service and select Stop Service -> next go to the Processes tab and click on it -> find iptray.exe from the list -> right-click on the Process and select End Process from the menu. Then see if you can install the update.


After the update is installed simply reboot to re-start Immunet.


Best wishes, Ritchie...

Link to comment
Share on other sites

Thank you for the help!


In case someone searches for this issue I'll layout what I did and what worked.


I had already tried excluding the folder.  That did not work.


I tried excluding RBX*.temp that did not work.


I even tried excluding .tmp and that did not work. 


I followed your suggestion to kill Immunet in the task manager...  Even though I was running with an administrator account, when I tried to shut down  Immunetprotect_6.0.8 from the services tab it gave me "Access Denied."  I have never been able to shut down Immunet from within the task manager.  I have always assumed that this a security issue where Immunet does not want just anyone or anything shutting down the service.


Following that line of thought... This is what worked.  I uninstalled Immunet.  Installed Roblox.  Then re-installed Imunnet.  Took just a few minutes and did get the job done.


Prior to Immunet I used to run ESET.  ESET has a "Temporarily Shut Off Protection" button.  I used to use that for installs that had issues.  I looked all over Immunet for this.  I even clicked off every selection in Immunet and still could not get the install to go through.  For gamers, it would be nice to have a "Temporarily Shut Off Protection" button.


Thank you for the help!!!  

Link to comment
Share on other sites

Hi LaniLani, glad to hear you got the update installed. That is unusual that you couldn't kill Immunet with TaskManager using your Admin. account. I can kill Immunet using this method.

That was a great idea though, to temporarily uninstall Immunet to update. Just hate to see you having to use such a method. I use to know the DOS Command Prompts that made it easy to stop and start Immunet without rebooting but these have changed or are nonexistent since version 5 unfortunately.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...