Jump to content
millard@immunet.com

Clamav For Windows Beta (Clamlib Integration)

Recommended Posts

This is a public beta for ClamAV For Windows with ClamAV libraries integrated. This gives you the advanced protection of the cloud with the signatures that ClamAV provides.

 

This contains:

  • Clam libraries for offline scanning version 0.96.5
  • Customizable signatures (Please follow this link for the user's guide: http://support.immunet.com/tiki-read_article.php?articleId=24)
  • Wildcard exclusions - specifically so we can exclude Thunderbird's %TEMP%\nsmail*.tmp
  • Unicode bug fixes
  • Bug fix for user's getting in a disconnected state

 

Because this is a Beta 1:

  • It is strongly recommended that you test on a VM
  • Make sure to have backups of your machine in case of any issues
  • Do not uninstall an existing AV product and rely solely on this
  • For Plus users, it's not recommended to run both Tetra and ClamAV as there is a large performance impact
  • Alpha user's should uninstall before trying to install the new version

 

Report Issues:

If you have any issues, please bring them up on this post and attach a support snapshot. If you're unable to attach the snapshot, please send to support at immunet.com the snapshot, a description, and any relevant screenshots.

 

Version 2.0.18.76 with ClamAV Libraries 0.96.5 can be found at

  • Like 1

Share this post


Link to post
Share on other sites

Hi Guys,

 

It just flashed in my mind that few days ago my whole Identity Safe (Norton 360) database didn't open itself when I tried to give its password. The password didn't work (no changes has been made) and also, i wasn't able to recover it... I am not 100% sure but maybe ClamAVP interfered somehow because that's the only beta software that i run?! ...needed to insert everything again...now it's working again...

 

I am sending the SDT in email as it's more than 8 megs.

 

Vik

Share this post


Link to post
Share on other sites

Hi Guys,

 

It just flashed in my mind that few days ago my whole Identity Safe (Norton 360) database didn't open itself when I tried to give its password. The password didn't work (no changes has been made) and also, i wasn't able to recover it... I am not 100% sure but maybe ClamAVP interfered somehow because that's the only beta software that i run?! ...needed to insert everything again...now it's working again...

 

I am sending the SDT in email as it's more than 8 megs.

 

Vik

 

Vik,

 

Easy way to find out would be to do this next time it happens:

 

c:\net stop immunetprotect

 

Give it a few seconds and then try the operation with your password safe. If it works then the issue is on our end, if not then it's another issue.

 

al

Share this post


Link to post
Share on other sites

Vik,

 

Easy way to find out would be to do this next time it happens:

 

c:\net stop immunetprotect

 

Give it a few seconds and then try the operation with your password safe. If it works then the issue is on our end, if not then it's another issue.

 

al

 

 

 

Thanks Al!

Share this post


Link to post
Share on other sites

1) Can we expect subsequent betas, RCs and the public release to be handled by the resident updater? Or do we need to check in here routinely to find out if 2.0.18.76 has been replaced by 2.0.NewerOne?

 

2) Does ClamAV act "...in a supporting role to the other Cloud Engines..." as does Tetra?

 

Thank you!

Share this post


Link to post
Share on other sites

1) Can we expect subsequent betas, RCs and the public release to be handled by the resident updater? Or do we need to check in here routinely to find out if 2.0.18.76 has been replaced by 2.0.NewerOne?

 

Signature updates are done via FreshClam. Product updates for Beta may depend on how frequently we release them. I may push for a 2.0.19 so we can use the in product updater. Any preference?

 

2) Does ClamAV act "...in a supporting role to the other Cloud Engines..." as does Tetra?

 

Thank you!

ClamAV acts very similar to Tetra in that we hand off files to the engine and register callbacks for results while performing analysis with the cloud engines.

--Millard

Share this post


Link to post
Share on other sites

hello guys.

 

not sure if it was from the hard restart of the physical pc (XP Pro, E6500, 3GB Ram) or if it was because of the beta but the virtual machine aparently was crashed.. windows failed to boot...

 

I'm using VMware Player 3.1.3 (i think) and this morning the vm and the physical pc where both freezed.. ocasonally responding.. i was getting late for work, so hard restart and tried remote acess from work.. now the vm says the windows can't boot.. not sure on how to get a iso mounted to trie repair the boot sector (like in a physical machine)

 

 

i'm makking a new VM, so i'll keep you posted...

 

PS: Signature updates are done via FreshClam. Product updates for Beta may depend on how frequently we release them. I may push for a 2.0.19 so we can use the in product updater. Any preference?

i think that we should have a notification in forum and on the app... like a ballon info... ;)

Share this post


Link to post
Share on other sites
Product updates for Beta may depend on how frequently we release them. I may push for a 2.0.19 so we can use the in product updater. Any preference?

Updater... what I call resident, you call in product. That's always preferable to the "download and install over" and "uninstall, download, install" methods. :)

 

With respect to current public releases of Immunet/ClamAV, the process when a new PRODUCT is released, a balloon tip makes the announcement. Right? (I'm still running Immunet 2.0.16.38 Free on my production box so I've forgotten the exact steps I went through way back then.)

 

Maybe I should have asked this instead: I'm running ClamAV 2.0.18.76 Free on my test system; when the next whenever it might be "whatever you might call it PRODUCT" is released, how will I be made aware of that event?

 

Cheers.

Share this post


Link to post
Share on other sites

Updater... what I call resident, you call in product. That's always preferable to the "download and install over" and "uninstall, download, install" methods. :)

 

With respect to current public releases of Immunet/ClamAV, the process when a new PRODUCT is released, a balloon tip makes the announcement. Right? (I'm still running Immunet 2.0.16.38 Free on my production box so I've forgotten the exact steps I went through way back then.)

 

Maybe I should have asked this instead: I'm running ClamAV 2.0.18.76 Free on my test system; when the next whenever it might be "whatever you might call it PRODUCT" is released, how will I be made aware of that event?

 

Cheers.

 

If we release it as 2.0.19, we have options:

* We can do the balloon pop-up and allow the product update to occur in the product without having to do the uninstall portion.

* We can send out a link to 2.0.19 in the Forum, and you can download an upgrade without having to do the uninstall.

However, if we go from 2.0.18.76 to 2.0.18.xx, then we have to force the uninstall.

 

I think the 2.0.19 is the best choice.

--Millard

Share this post


Link to post
Share on other sites

If we release it as 2.0.19, we have options:

* We can do the balloon pop-up and allow the product update to occur in the product without having to do the uninstall portion.

* We can send out a link to 2.0.19 in the Forum, and you can download an upgrade without having to do the uninstall.

However, if we go from 2.0.18.76 to 2.0.18.xx, then we have to force the uninstall.

 

I think the 2.0.19 is the best choice.

--Millard

 

 

Millard,

 

For me is ditto. Personally, i would do this with pop-up... in the meantime, you could also send the link for us...what if the pop-up won't work 100%?

 

Vik

Share this post


Link to post
Share on other sites

Millard,

 

I have few possible problematical issues in ClamAVP' daily operation:

 

I ripped a Blu-ray disc and converted it to an 8.5 GB H.264 MKV format video and changed its language file to another. Now, this was few months ago when I ran IPP. The WMP, DivX Player and KMPlayer were able to play it without any problems. Yesterday, I tried to burn a DVD movie from it but wasn't able because from the moment that the MKV file was copied to my HDD, the RAM went to 95-99% all the time and the system simply didn't respond. I needed to manually reboot. The situation changed from bad to not that bad only a bit. I wanted to delete or erase the MKV file without any success. Since the file was noticed by ClamAVP, the software blinked all the time. Even when I didn't work with the video file. Seems that its present caused this for ClamAVP i.e. for the OS. After this I chose the System Restore from the OS but after the seemingly successful restore the program dropped this Error Message (0xc0000022). I did this a dozen times without success and the ClamAVP' turbidity and the heavy RAM usage simply interfered in running the OS. The only thig that immediately worked when I used Ubuntu 10.10 live usb, which deleted the file without any hesitation. After this the windo0ws 7 loaded as earlier and the file wasn't in the folder anymore. ClamAVP is also behaves as a good boy now. No nervous blinking and crying....

 

SDT file will send in email, because of its size.

 

Vik

Share this post


Link to post
Share on other sites

Seems to interfere with Netflix player causing spurious errors - like already watching instantly. Turn off ClamAV service and Netflix plays fine.

 

Firefox 3.6.9

Vista Business Service Pack 2

Share this post


Link to post
Share on other sites

does this beta receive daily updates for the ClamAV? have it installed on a old machine (XP lited, celeron OC 525Mhz, aprox 300MB ram 20GB HDD ide...) but i only can get it on-line throw cable... the wi-fi pci card doesnt install (maybe because of the lited xp).... havent getted on.line since installed the SO and ClamAV beta...

Share this post


Link to post
Share on other sites

thats strange... because yesterday i've used a VM using VirtualBox that was setup a couple of days a go and clam didn't get any updates (excepted the ones after install)

Share this post


Link to post
Share on other sites

i think that i've manage to get it to update... normally i click for updates and wait until it says anythig... but seems that clam requires some secunds (10/15 sec) and then checks for the av updates for database sigs...

Share this post


Link to post
Share on other sites

Status Update:

 

Some of you have asked for a status update and I've been behind on passing some information along. In about an hour, I am getting a new version of the ClamAV For Windows Beta. It still has three known issues to address and there is a feature which I haven't tested at all. A lot of changes have been added to the copy/move/execute functionality so of course we've broken a lot of things. Hopefully all of those are in this release, but if not then subsequent ones will be coming for testing (with fixes to the known issues).

 

As for dates, I need to follow-up with Al. I think I'm going to aim for Jan 25th put out a new Beta release (2.0.19 for upgrade purposes). The quality of the next Beta will drive the Final release date, but I expect mid-February with another beta drop before then.

Share this post


Link to post
Share on other sites

Status Update...

Thank you!

 

When the announcement is posted up, could there be please (Please!) be included the method by which an existing 2.0.18.76 install be upgraded? In-product "Update Now"? Uninstall .18, install .19? Run the .19 installer "on top of" the installed .18? Or what?

 

Cheers.

Share this post


Link to post
Share on other sites

2.0.19 is now available. You can download it and install over any existing version include the 2.0.18 beta release.

 

Downloads:

32-bit: http://download.immunet.com/binaries/clamav/bin/clamav-en-us-2.0.19.8-32.exe

64-bit: http://download.immunet.com/binaries/clamav/bin/clamav-en-us-2.0.19.8-64.exe

 

Or, assuming everything is good, you can wait until tomorrow morning and I'll push the upgrade for any of the existing 2.0.18 beta users so that you get the balloon pop-up saying an upgrade is available. Both paths are the same.

 

NOTE: Your current history will be removed during the upgrade. That means you will not be able to restore from quarantine and your last scan time will be lost.

 

Changes:

* Improvements to executing malware to catch it faster

* New detection dialog box that stays up while you're detecting malware and has the filename and the detection name in it. It also allows you to page through detections.

* Fixes for offline scanning, missed detections, and signature updates for Clam

* Changes to the database schema for better collection of information

* Ask toolbar has been removed

 

Next we'll be putting some final touches based on anything found in the field and start labeling this as 3.0 with the expectation to release it early to mid-February.

  • Like 2

Share this post


Link to post
Share on other sites

thanks for the update. downloading to VM at the moment....

 

when can we expect to have immunet our clamav using the translations?

 

keep the good work!

 

mokito

Share this post


Link to post
Share on other sites

thanks for the update. downloading to VM at the moment....

 

when can we expect to have immunet our clamav using the translations?

 

keep the good work!

 

mokito

I've asked the developers to add any new strings to the translator site (I'm only aware of a new detection string, but there might be more) and then start the language builds so I can start testing them. I probably won't know what state we're in until next week (I'm getting another QA to help test next week).

--Millard

Share this post


Link to post
Share on other sites

thanks for the info on that...

 

i'm posting some screenshot opf some gui issues.... clamav beta running on a vmware workstation 7.1.3 with seven hopme basic, threatfire and widnows defender....

 

i'll attached the screenshots asap...

 

EDIT: screenshots posted!

 

post-104-042722500 1296049729_thumb.jpg

 

 

post-104-021061800 1296049741_thumb.jpg

Share this post


Link to post
Share on other sites

thanks for the info on that...

 

i'm posting some screenshot opf some gui issues.... clamav beta running on a vmware workstation 7.1.3 with seven hopme basic, threatfire and widnows defender....

 

i'll attached the screenshots asap...

 

EDIT: screenshots posted!

 

strange behaviour gui  full scan.jpg

 

 

strange behaviour gui.jpg

 

That's really ugly. Is that the latest version of IE9? If so, it looks like it make our product even worst. Before, it would blank when scanning and the drop shadow behind the phone number looked bad, but now it looks completely unusable. Also, can I get the exact IE version down to the build number.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...