Jump to content

Immunet doesn't remember settings

Recommended Posts

I've tried a fresh install of Immunet twice now, with the same behaviour. The version I currently have installed is Machine is Windows 10 Pro x64. If I open the settings dialog, change the settings from default (for instance, ask on detection / blocking mode / scan inside archives / scan packed), and hit apply, the settings are not remembered after reboot (or after quitting and restarting the immunet tray icon, or restarting the immunet service).

Expected behaviour: My settings persist until I change them

Actual behaviour: Default settings return after restarting PC or Immunet tray client or Immunet service.

Steps to reproduce: 1. Change and apply settings in the settings dialog. 2. Restart either IPtray, Immunet service(s), or PC. 3. Return to settings dialog and check settings.

Link to comment
Share on other sites

I have just noticed another thing: The settings are forgotten if you run a scan.

Steps to reproduce:

1. Change and apply settings.

2. Run a flash scan.

3. Return to settings dialog.

Expected behaviour: my settings persist

Actual behaviour: my settings forgotton; settings returned to default.


Just to confirm everything is online (I can scan etc) and no error messages are appearing.

Link to comment
Share on other sites

Sorry to hear you're having settings issues zombunny.

It's sounds like some of your .db history files may have become corrupted.

When you uninstalled did you use the option of "not saving your previous settings" by clicking "NO" when prompted by the uninstaller? This option will delete all your previous settings by clearing the related .db files. If you haven't tried that I think it may be worth another uninstall & reinstall effort.

Link to comment
Share on other sites

  • 1 month later...

Hi all, apologies for resurrecting an older thread, but I simply haven't had the chance to reply. In the interests of courtesy and helping others with similar issues in the future, I thought I'd reply.

I had already tried uninstalling (and thought I'd clicked "no" to the "remember stuff?" dialog) - however I did it again, just to be sure. I then ran the Windows built-in disk cleaner, Revo Uninstaller's "search for junk files", Bleachbit, and CCleaner, to ensure I'd removed all temporary files, orphaned registry entries, etc.

I also manually searched for any immunet traces by using "dir /s/a/b/p *immunet*" from the command line, from the root directory of drive C. You can use a similar technique to search for anything cisco, sourcefire or clamav related, but in my case it didn't reveal anything Immunet-related, and risks identifying other software. It's then just a case of using "del" and "rd" as appropriate to remove any traces of Immunet (there were virtually none). (There might be a GUI-based way of doing this, but MS generally try to hide directory-structures and system files in their GUI dialogs, so it probably won't work. It was very easy in WfW/Win9x/NT/2000, but I think something changed from XP onwards. If you want to just get something done, cmd is your friend)!

Finally, a reboot and clean reinstall of Immunet and it was working fine again. I'm not sure which of these actions cleared the relevant temporary files or database-files that were causing the problem, but this sequence of steps fixed it.

Edited by zombunny2
Link to comment
Share on other sites

Hi zombunny2,

Glad to hear you fixed the issue you were encountering! Sorry to hear you had to go through so much stuff to achieve that though.

My personal opinion is that Immunet needs a comprehensive removal tool developed, that will work with the newest builds, to clean all traces of the software just in case.

Cheers, Ritchie...

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...