Jump to content
Yodamin

windows 2012R2 Server CPU usage pegged on flash and Full scans

Recommended Posts

Can we please get a "run at low priority" setting while scanning?

 

Newly installed Windows 2012R2 Srv Standard with only Desktop Experience installed and DNS role running.

The PC:

i7 - 4790 @ 3.6 HyperThreading ON (it runs steadily at 3.8'ishGHz according to task manager)

16GB DDR3 1600 ram

Kingston SHFS37A120GB SSD (no other drives yet).

The CPU sits pretty much around 1-2% when idle (and I am checking this while logged in remotely with RDP)

The CPU burst to %15-18% when opening applications (also while logged in remotely - I don't usually sit at the srv keyboard, even though it's right behind my desk)

This is the MAIN DNS for both my router and the house. I have about 15 devices connected at all times and upt o 35-40 may be connected at once. I have only ever seen the CPU go over %20 once in a while due to server network load and normal daily usage of this house see's CPU usage sit between 1-6%).

Whenever I manually start a flash-scan or a full-scan of Immunet 7.0 the CPU usage pegs itself 100% CPU usage within 20-30 seconds of initiating the scan.

My router also runs snort in blocking mode and pfBlockerNG. I have blocked all countries using DNSBL except for Canada\U.S.\US Virgin Islands and Britain. on the inbound. Outbound is open to wherever (unless it's on one of the emerging threats lists).

I have disabled snort\pfBlockerNG and cleared all the blocked hosts and alert logs and immunet still exhibits the same behavior.

Is there a way to restrict Immunet to a low priority even while scanning?

 

It doesn't hog much juice at all while it is just monitoring, even if it catches something (and it has) it doesn't go much oer 2-3% CPU usage. It only happens when I initiate a flash\full scan or when it is initiated by schedule.

 

AT 3AM I can hear the CPU and case fans ramp up on my DNS server and the few times I've checked by remotely logging in and opening task manager to see who the culprit is - it is always because of Immunet.

I like Immunet a lot - it does a great job and is one of the few, if not the only, Antivirus that is available for free on Windows Servers.

Edited by Yodamin

Share this post


Link to post
Share on other sites

Hello Yodamin,

Have you experimented with the settings at all? Try temporarily turning off Blocking Mode in Settings before doing a scan to see if that has any positive results.

Are you using the ClamAV module enabled at this time? Also, do you have Scan Archive Files & Scan Packed Files enabled within the Scan Settings tab?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...