Jump to content
VanPrat

Extremely high CPU usage

Recommended Posts

Using a Windows 10 laptop here. Every time I start my laptop or resume from sleep mode, the laptop and applications are becoming practically unusable due to extremely high CPU usage by Immunet 7.0.2. This started sometime in the last 7 - 10 days. I am running the latest, patched version of Windows 10 as also Norton AntiVirus. I have been using the same set of applications in the laptop the past 4-5 years and this is the first instance of Immunet CPU usage spiking up.

Please take a look and help! As of now, I am resorting to kill Immunet tasks. Also uninstalled & reinstalled but nothing has changed.

Share this post


Link to post
Share on other sites

Hi VanPrat,

There is the option to enable Verbose Tray Notifications which is for troubleshooting purposes. With this setting enabled you'll get a pop-up message for the files Immunet is interacting with. Maybe that will give you some idea what files/program may be causing the spike in CPU resources with Immunet. Just keep in mind when this setting is enabled you may get "numerous" pop-up messages.

To enable Verbose Tray Notifications first open the UI -> click on the Settings tab ->  scroll down to the Notifications Settings tab & click on that -> turn ON Verbose Tray Notifications -> minimize the Notifications Settings tab ->  click Apply then Close. Then re-start your computer.

If you can't determine what program might be causing a conflict there is another option of sending in a Support Diagnostic Tool report for the devs to look at.

Let us know if you need to send in a SDT report. I can give you detailed instructions on how to do that. Leave VTN on for now until the SDT report is sent in would be my recommendation.

I've repeated this before for the forum community but it's worth mentioning again, unless "instructed to do so" please "do not" turn on Verbose Tray Notifications.

Regards, Ritchie...

Share this post


Link to post
Share on other sites

Hi VanPrat,

I was having the same problem until I discovered the "monitor program start" was enabled by default.  I found that, especially when trying to start programs or intensely use programs, CPU usage was insane and rendered the computer almost unusable. 

Since then, I turned off the setting and CPU usage went back down to normal.  I would take an educated guess that, when you have "monitor program start" enabled in the Immunet settings, it applies to any time a new process gets started on your computer.  This could even be triggered by loading several tabs in your browser as, the more tabs loaded, the more processes get started by the browser.

Please also note that when a scan is taking place, the load is pretty high on the CPU.  I think putting it in gaming mode should lessen it's load a little bit during a scan. You might also check your scan schedule and make sure your scheduled scans are for off-hours when your computer will be on, but not being used.

Hope that helps a little.

Edited by 50m30n3

Share this post


Link to post
Share on other sites

Personally I don't use that setting enabled myself either. I seems to interfere with some of my other security start-up programs at boot-up.

Share this post


Link to post
Share on other sites

Most likely a program running in the background, look at what is using the most amount of CPU % when it jumps up high again. Windows commonly uses a lot when the PC has been off for a few days, this is for updates and other things. 

Edited by WilliamKing321

Share this post


Link to post
Share on other sites

If you are running Immunet in parallel with another AV like Norton, you can safely disable the ClamAV module in Immunet. ClamAV is very CPU-intensive, and you may find that this is the component that's causing the CPU-spike. I personally leave ClamAV enabled, because I often add custom signatures to it - but it does really hammer that CPU.

You should also make sure you've gone into Immunet's settings and excluded Symantec/Norton's directories under %programfiles%, %programfiles(x86)% and %programdata% as relevant/necessary.

You may also want to add Immunet's folders to Norton's exclusions (these are %programfiles%\Cisco\Immunet, %programfiles%\Immunet, %programdata%\Cisco\Immunet, %programdata%\Immunet if you are running 64-bit).

I'd be willing to bet a lot of your trouble is Norton and Immunet scanning each other whenever they do anything.

As WilliamKing321 states, updates and things also cause this behaviour. I know when my W10 is running an update because Immunet in particular starts consuming massive resources scanning it all. And seeing as I'm a fairly infrequent Windows user, this is very noticeable every time I have the misfortune of needing to boot that operating-system.

  • Like 1

Share this post


Link to post
Share on other sites

Something that can help reduce both Immunet's system resource usage, & more importantly the time it takes to update, is to temporarily disable 'Blocking Mode' (if enabled) in Settings 'before' you start Microsoft Windows Updates for your Operating System. That's what I do.

If you normally use Blocking Mode with Immunet just don't forget to turn it back on after Microsoft is done downloading & installing the updates (change the setting only after any necessary Windows re-boot(s) is/are completed first too).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...