Jump to content

Recommended Posts

Is updating broken again?

I was getting alerted that an update was available, but no matter how many times I clicked on "Update Now" or on "Fix It" the download would time out and retry, but never succeed at downloading.

I downloaded the latest version 7.3.0.11792 manually from the website, and installed it.  Now the "!" mark is still showing with a "Not Updated" status.  Clicking on "Fix It" or "Update Now" responds with "Immunet is Up to Date", "Checking for definition updates", "Latest updates already installed", but the "Not Updated" status remains.  Rebooting makes no difference either.

Anyone else experiencing this?

Not_Updated.png

Share this post


Link to post
Share on other sites

Some users that have run into this same issue have had success by doing a clean uninstall & reinstall. By a clean install I mean when asked by the uninstaller if you plan to install Immunet again choose the "NO" option and proceed with the remainder of the uninstall. 

When you reinstall Immunet again you will have to reconfigure the settings to the way you had them & add any custom exclusions you may have been using. Worth a try I think.

Share this post


Link to post
Share on other sites

I noticed that I get the "not updated" status on a fresh install until I manually perform a scan (even just a "flash scan" will do - and it only takes a minute or two). Even after manually updating Immunet, I noticed that closing and re-opening the GUI (or restarting the computer) resulted in the "not updated" status. The only way to fix it was to update then scan.

On every machine I've tried so far (all some variant of Windows 10), the following seems to fix it:

1. Open Immunet GUI
2. Manually check for updates. Wait a few minutes, to give the ClamAV database a chance to update, then close the update dialog.
3. Now run a flash scan (or full scan, but beware a full scan can take hours whereas a flash scan only takes minutes).

It seems as if forcing an update then forcing a scan resets Immunet's indicators and it all works again.

  • Like 1

Share this post


Link to post
Share on other sites

Glad to hear that zombunny's procedure worked for you Monk. It doesn't seem to work for everyone however.

Another user reported that a reinstall worked instead. I know that really is a less than ideal fix though.

Build 7.3.0 definitely has some bugs that need to be addressed ASAP in my view!

Regards, Ritchie...

Share this post


Link to post
Share on other sites

@zombunny2:  Since my version was already up to date, your solution did not work for me.  Thank you for the suggestion though.

@ritchie58:  Thank you.  The complete uninstall did the trick.  I hope the future updates don't need that workaround.

  • Like 1

Share this post


Link to post
Share on other sites

Hi guys, if my solution doesn't work for you it's precisely because you're not doing it as the very first thing on a completely fresh installation.

I always completely remove Immunet, say "no" to keeping all data, reboot and do a fresh install. I've only ever had problems when upgrading Immunet via the GUI so I just never chance it any more.

Sorry, I forgot to make that bit completely clear.

Share this post


Link to post
Share on other sites

I have version 7.3.011792. It works fine for a week or two  after a complete uninstall telling immunet I will not re-install - remove all files  I also go into the directory to be sure every thing is gone and delete completely anything left and restart..  It works fine a week or two, the it is back to the same thing - immunet up to date but it indicates a problem. I poked around a little trying to narrow down the problem.  If you turn off "Enable ClamAV Engine" in settings (leave update definitions on), it IMMEDIATELY fixes the problem.  Apparently the newest version is unable to always use the ClamAV engine and returns the error.  Virus definitions and Immenet interface are up to date, but ClamAV is not enabled.  It looks as if Immunet does not patch problems.  I don't know that ClamAV can be successfully updated manually, but since the virus definitions update, turn off update ClamAVEngine in settings to avoid the error message.  Maybe  Immunet will fix the problem in the next big release.  If the error message does not go off when you turn off enable ClamAV engine, ClamAV may not be the problem.  Keep looking.

Edited by JimNva
  • Thanks 1

Share this post


Link to post
Share on other sites

Thanks for the extra input on this issue Jim. I do appreciate you reporting this.

This is the first posting that a clean reinstall didn't seem to work! "Sorry to hear that bro!"

What is your Operating System anyway Jim?

I too truly hope the devs are reading these recent issue postings since I'm not exactly getting a whole lot of help on this site lately.

I believe that your observations are correct. It seems the issue solely lies with the ClamAV module. This has been and continues to be a non-issue for me since I don't use ClamAV. I got Immunet paired as a companion AV to a different paid AV product. It is recommended that the ClamAV module & updates for it be disabled if Immunet is used in this manner.

Sincerely, Ritchie...

Share this post


Link to post
Share on other sites

Hi Ritchie58,

I am using windows 10.  I saw Franks solution to manually update ClamAV.  It seemed to work flawlessly, but the error reoccurred today - same thing - Clam AV engine is the problem.  However, I need to redo the solution Frank posted in case I messed something up.  The error may have returned because I did something wrong.  I'm posting Frank's solution below that I need to try again.  Hopefully, I just did something wrong. I might mess with it this week.  Of course, I used window powershell  to run the command  'net stop ImmunetProtect_7.3.0'  It may be that this works great for 7.2.8, but 7.3.0 has another issue with the ClamAV engine that this does not fix.  It takes a little while before the error reoccurs, so it is hard to evaluate is the message is solved quickly.

Frank's solution to update ClamAV engine

Solution 1

  1. Download clamav-0.102.3-win-x64-portable.zip from https://www.clamav.net/downloads#otherversions
  2. Stop the Immunet Service --> net stop ImmunetProtect_7.2.8
  3. Delete old Database files bytecode.c*, daily.c*, main.c*, lastupd and update.log
  4. Extract the files to C:\Program Files\Immunet\clamav\0.102.1.76
  5. Start the Immunet Service --> net start ImmunetProtect_7.2.8
  6. Start Immunet, Click on Update Now and wait a moment (if Update does not start repeat it after a min.)

The download location is configuratet in the file freshclam.conf, if you need to use a other mirror change it in this file.
 

Edited by JimNva
poor typing skills

Share this post


Link to post
Share on other sites

Based on comment at 2020-07-12 17:14 (don't know time zone, the chat doesn't show it) from JimNva and answer from ritchie58 I searched a bit more and found that, on my two systems, Immunet may be looking on the wrong file or logs to determine the date of last update:

What i think is happening is that ClamAV uses a set of files to the virus database, extension cvd and cld (there may be others). I see bytecode.cvd, main.cvd, windows.cvd and daily.cld. While bytecode.cvd and main.cvd are older, about 4 days, the windows.cvd and daily.cld is newer, from today. Immunet is reporting the modification date from the older files that (I think) are updated less often, instead of the date of one of the two newer.

Also a better place to search for is the file lastupd, modified today and that has the date of the database version on its contents, yesterday: 2020 Jul 20 11:31:24 I beleave (hope) that this is UTC.

If this is it, it will be a lot easier to the devs than it looked!

Edited by fbiazi
Add information about file lastupd

Share this post


Link to post
Share on other sites

None of this works.  Clam AV works for a while then the update problem reoccurs .  ClamAV pushed a patch put, and this means that ClamAV is outdated again,  I,mmunet does't handle this change well, and that means this will be a constant PIA.  I unloaded Immunet and loaded CLAMWIN to perform daily scans,  I will reload Immunet without CLAMAV , if there is any benefit to doing that.  CLAMWIN does not automatically check files in real time like IMMUNET does. If Immunre can scan files loading on my computer in real time  without CLAMAV, I will load it.

 

The solution Frank posted still works correctly. The file clama0.102.3-win=x64-portable.zip is now outdated, and as a result, ClamAV is outdated.  Follow  Frank's instructions, but download the latest file ( now it is clama0.102.4-win=x64-portable.zip)  from https://www.clamav.net/downloads then follow Frank's instructions as he posted (I re-posted them above too).

Fbizai, run freshclam.exe as administrator and see if that works.   It is in the subfolder 0.102.76 in the clamav directory in the Immunet folder in Program Files.  If it does not, then try deleting the old database files bytecode.c*, daily.c*, main.c*, lastupd and update.log in the Clam AV directory, BUT BE SURE TO USE WINDOWS POWERSHELL  AS ADMINISTRATOR to stop the Immunet service first, using the commands re-posted above.  After restarting the service, run "update now" a couple of times.  It may take a few minutes before the system is able catch up so that "update now" correctly runs.  At some point, the files deleted are downloaded fresh or rebuilt.  I have only done this in the context of updating ClamAV and it works fine there.  Assuming your ClamAV is the most current version (run freshclam.exe to find out) things should work fine.  In Immunet in the ClamAV directory is the subfolder 0.102.2.79.  I leave that folder name intact because Frank's original instructions did not indicate it should be removed.  I just unzipped the most current ClamAV engine into that subfolder.  I would not change that subfolder name because I don;t know if it is "hardwired" onto the Immunet code.  If you have changed that, it might cause problems.  Freshclam.exe tells you if your engine is outdated. I think deleting those database files and allowing Immunet to update to download or update new files will fix your problem.  If I am wrong, you will have to remove  Immunet and do a clean install.

Edited by JimNva
Doesnot fix error message - merror meaasage keeps reoccuring because immunet incapable of keeoing clamav ep tp date

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...