Jump to content
sweidre

Bug: Latest Scan Time Is One Hour Ahead

Recommended Posts

When using the Swedish version of Software Version 3.0.1.6056 (clean install today after complete uninstall of 3.0.0.8 English Version), "Latest Scan" (or "Last Scan") is showing 2011-04-10 16:09:57, when the latest scan in fact was done 2011-04-10 15:09:57 as shown on my computer.(Note, that my computer was properly automatically updated to summar time during the night on 27th of March, when all Swedish clocks were adjusted 1 hour forward). Anyhow Swedish time should always be GMT+1 hour. I can not send any System Diagnostic Tool log, because it seems to be another bug in this version. When clicking on its icon I receive a message box in Swedish language saying as per my translation back to English:

 

"Immunet Protect Diagnostic Tool

Immunet Protect Diagnostic Tool has ceased to function.

A problem caused the program to function correctly. The program will be terminated and you will receive a report, if there is any solution to the problem."

 

I pressed the button with the text: "Close Program" and the error box disappeared.

 

So I cannot by email send any result from the Diagnostic Tool!

 

OK, I intended not to report this bug regarding the Immunet Protect Diagnostic Tool now, but only the 1 hour difference bug.

 

Details of my computer softwares I have moved from my signature to my (sweidres) profile page. There click on "About me" and all my softwares with versions numbers are shown there.(updated today!) It is a lot!

Cheers,

sweidre

 

PS. No Diagnostic Report could be emailed to Immunet! DS.

Share this post


Link to post
Share on other sites

Hi again,

Preamble: Yesterday I installed the Swedish Beta-version 3.0.1.6056 (64-bit), and I found only two truncation errors, because of too short fields! I went to the website https://translator.immunet.com/ , and there I shortened two strings, so hopefully the next issue of the Swedish version will be correct to 100% then! I am the Swedish translator, but I prefer to use the English version when communicating with forum fellows. So today, I turned back to the English version 3.0.0.18 (64-bit) by using an image (Norton Ghost Backup) of my systemdrive done just prior to changing from the English to the Swedish version. (Note, that all changes from one version to another one are always made by completely uninstalling of one version and then a clean installation of the second. (So nothing is inherited from one version to the other one, so all new settings are done from scratch!) After having done a scan, I noticed, that Last Scan Time was shown exactly one hour ahead of the real time here in Sweden. (It´s a little bit strange, that the time shown on my computer is not in sync with the time shown as Last Scan Time. (minutes & seconds are in sync, but not the hour).

 

Time Zone UTC+1 hour (GMT+1 hour): The Western European continental countries belong to this time zone eg. Amsterdam (The Netherlands), Berlin (Germany), Bern (Swizerland), Paris (France), Madrid (Spain), Roma (Italy), Brussels (Belgium), Stockholm (Sweden), Oslo (Norway), Copenhagen (Denmark), Vienna (Austria).

 

Bug: So both the English version 3.0.0.18 (64-bit) and the Swedish Beta- version 3.0.1.6056 (64-bit) are showing the Last Scan time exactly one hour ahead of my computer time! (Computer time is updated automatically)

 

Reason alternatives:

1.) Immunet has placed Sweden in a time zone for Eastern Europe

2.) Summertime (1 hour ahead of Wintertime) exists in many countries, but not all. This fact can cause confusion! Switches between summertime & wintertime are done twice per year (a Sunday night at 02:00 AM after the 21 March and the 21 September in Sweden).

 

Alternative solutions:

1.) Immunet Protects Last Scan Time should always be in sync with the time of the computer.

2.) Last Scan Time should be deleted, because it is of no interest at all!

3.) Let the Last Scan time show one hour ahead (nobody cares!)

 

Cheers,

sweidre

PS: In my mind there are more important things, that should be improved in Immunet Protect. Forget the Last Scan time! DS.

Share this post


Link to post
Share on other sites

Hi Sweidre, I have tried to reproduce the support tool crash but haven't been able to. Normally I'd suggest an uninstalling (makeing sure to select *no* when asked if you plan to reinstall) and reinstalling, but it sounds like you've done that already. Can you check a few things:

 

1) Click Start -> Programs -> Immunet 3.0 -> right click the Support Diagnostics Tool and select properties, and check that on the Shortcut tab, Target is set to "C:\Program Files\Immunet\3.0.1\ipsupporttool.exe

 

2) Reboot, then try running "C:\Program Files\Immunet\3.0.1\ipsupporttool.exe" directly and see if it still crashes

 

3) Open "C:\Program Files\Immunet\3.0.1\" in windows explorer, right click ipsupporttool.exe and select properties, then open the details tab and check the file version is 3.0.1.6056.

 

4) Open c:\windows\system32\drivers\ and verify ImmunetProtect.sys, ImmunetSelfProtect.sys, and Trufos.sys all exist.

 

Please let me know how it goes.

Share this post


Link to post
Share on other sites

Hi Sweidre, I have tried to reproduce the support tool crash but haven't been able to. Normally I'd suggest an uninstalling (makeing sure to select *no* when asked if you plan to reinstall) and reinstalling, but it sounds like you've done that already. Can you check a few things:

 

1) Click Start -> Programs -> Immunet 3.0 -> right click the Support Diagnostics Tool and select properties, and check that on the Shortcut tab, Target is set to "C:\Program Files\Immunet\3.0.1\ipsupporttool.exe

 

2) Reboot, then try running "C:\Program Files\Immunet\3.0.1\ipsupporttool.exe" directly and see if it still crashes

 

3) Open "C:\Program Files\Immunet\3.0.1\" in windows explorer, right click ipsupporttool.exe and select properties, then open the details tab and check the file version is 3.0.1.6056.

 

4) Open c:\windows\system32\drivers\ and verify ImmunetProtect.sys, ImmunetSelfProtect.sys, and Trufos.sys all exist.

 

Please let me know how it goes.

Hi RobT,

You have not properly read my two posts above! After having done necessary changes at the translators site, I decided to go back to the English version 3.0.0.18 by "overwriting" my systemdrive with an image (Norton Ghost) from the day before. I regard the Swedish translation work as finished. I will continue to use the English version only, so that I can properly give instructions in the forum based upon the English language. (I have not seen any active Swedish users in the forum yet!) So I will continue using English final versions only (not Beta).

Cheers,

sweidre

Share this post


Link to post
Share on other sites

Hi RobT,

You have not properly read my two posts above! After having done necessary changes at the translators site, I decided to go back to the English version 3.0.0.18 by "overwriting" my systemdrive with an image (Norton Ghost) from the day before. I regard the Swedish translation work as finished. I will continue to use the English version only, so that I can properly give instructions in the forum based upon the English language. (I have not seen any active Swedish users in the forum yet!) So I will continue using English final versions only (not Beta).

Cheers,

sweidre

Hi all,

The Last Scan time in Immunet shows exactly one hour ahead of my official Swedish time shown in my system tray. Has anybody come across this minor problem in his/her computer? If so, please, drop a line hear on this thread. Is the bug found in my computer only, is it found in other Swedish computers, is it found in other computers regardless of country?

Cheers,

sweidre

Share this post


Link to post
Share on other sites

Hi all,

The Last Scan time in Immunet shows exactly one hour ahead of my official Swedish time shown in my system tray. Has anybody come across this minor problem in his/her computer? If so, please, drop a line hear on this thread. Is the bug found in my computer only, is it found in other Swedish computers, is it found in other computers regardless of country?

Cheers,

sweidre

Hi,

RobT & I have started a private (PM) thread on this issue.

Cheers,

sweidre

Share this post


Link to post
Share on other sites

Hi,

RobT & I have started a private (PM) thread on this issue.

Cheers,

sweidre

Hi,

RobT & I have found the root of the problem. It is a minor bug (one hour difference) between Last Scan time on the front page and in History-> File History -> Scan History. That will be an easy fix by the Immunet programmer. (So Case is almost closed!)

Cheers,

sweidre

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...