Jump to content
Rob.Turner

3.0.1.6056 Last Updated Icon Always Displays "not Updated"

Recommended Posts

I'm afraid there was a bug in the 3.0.1.6056 release: the Last Updated icon in the Immunet interface always displays a yellow exclamation mark along with a "Not Updated" status, even though it's fully updated. This bug only affects users that upgraded from a previous versions, and does not affect Immunet's virus definition update mechanism (i.e. your virus definitions are in fact up to date, even though the interface indicates they are not). This bug does not affect anyone installing Immunet for the first time, or who manually uninstalled before installing the 6056 version.

 

Due to the forum feedback and volume of support calls we've received for this issue we released a new version 3.0.1.6112 on March 14/2011. Users who currently have 6056 installed will *not* be prompted to download this version and instead should apply the following fix:

 

------------------------------

1) Open an elevated command prompt by clicking Start -> All Programs -> Accessories -> Right click on "Command Prompt" and select "Run as administrator"

 

2) Copy following lines below, right-click on the Command Prompt window and select paste to run them (make sure to hit enter if the last line doesn't run):

 

net stop immunetprotect

IF EXIST "c:\Program Files\Immunet" set DIRNAME=Immunet

IF EXIST "c:\Program Files\Immunet Protect" set DIRNAME=Immunet Protect

IF EXIST "c:\Program Files\ClamAV for Windows" set DIRNAME=ClamAV for Windows

copy /Y "c:\Program Files\%DIRNAME%\update\Plugins\update.txt" "c:\Program Files\%DIRNAME%\tetra\Plugins\update.txt"

net start immunetprotect

 

If this runs correctly you should see "1 file(s) copied" when the copy /Y... line is executed. If there were any errors the copy /Y... line will return "The system cannot find the path specified."

 

3) Now, open Immunet and wait for it to connect to the cloud - once you are connected the Community icon should will turn green and you will see the Community message at the top saying 1 million users protected from 23 million threats. Click the Update button - when the update finishes you should see the update icon change from yellow to green.

------------------------------

  • Like 1

Share this post


Link to post
Share on other sites

I'm afraid there was a a bug in the 3.0.1.6056 release: the Last Updated icon in the Immunet interface always displays a yellow check mark along with a "Not Updated" status, even though it's fully updated. This bug only affects users that upgraded from a previous versions, and does not affect Immunet's virus definition update mechanism (i.e. your virus definitions are in fact up to date, even though the interface indicates they are not). This bug does not affect anyone installing Immunet for the first time, or who manually uninstalled before installing the 6056 version.

 

Due to the forum feedback and volume of support calls we've received for this issue we released a new version 3.0.1.6112 on March 14/2011. Users who currently have 6056 installed will *not* be prompted to download this version and instead should apply the following workaround:

 

------------------------------

1) Open an elevated command prompt by clicking Start -> All Programs -> Accessories -> Right click on "Command Prompt" and select "Run as administrator"

 

2) Copy following lines below, right-click on the Command Prompt window and select paste to run them (make sure to hit enter if the last line doesn't run):

 

net stop immunetprotect

copy /Y "c:\Program Files\Immunet\update\Plugins\update.txt" "c:\Program Files\Immunet\tetra\Plugins\update.txt"

net start immunetprotect

 

3) Now, open Immunet and wait for it to connect to the cloud - once you are connected the Community icon should will turn green and you will see the Community message at the top saying 1 million users protected from 23 million threats. Click the Update button - when the update finishes you should see the update icon change from yellow to green.

------------------------------

Hi,

1. I made a complete uninstallation of Eng. v.3.0.1.6056 Free (Cloud Only Version)

2. Downloded new version from http://www.immunet.com/ - The download button was still not provided with any version number, but I continued anyhow! - (Pls, provide the button with version number!)

3. Installation of downloded version (I selected alternative 1: Cloud Only)

4. When installed, Immunet showed version 3.0.1.6112 (Good!)

5. Made the settings incl. scheduled scans

This method worked excellent (at least for Immunet Free - Cloud Only)

Cheers,

sweidre

Share this post


Link to post
Share on other sites

I'm afraid there was a a bug in the 3.0.1.6056 release: the Last Updated icon in the Immunet interface always displays a yellow check mark along with a "Not Updated" status, even though it's fully updated. This bug only affects users that upgraded from a previous versions, and does not affect Immunet's virus definition update mechanism (i.e. your virus definitions are in fact up to date, even though the interface indicates they are not). This bug does not affect anyone installing Immunet for the first time, or who manually uninstalled before installing the 6056 version.

 

Due to the forum feedback and volume of support calls we've received for this issue we released a new version 3.0.1.6112 on March 14/2011. Users who currently have 6056 installed will *not* be prompted to download this version and instead should apply the following workaround:

 

------------------------------

1) Open an elevated command prompt by clicking Start -> All Programs -> Accessories -> Right click on "Command Prompt" and select "Run as administrator"

 

2) Copy following lines below, right-click on the Command Prompt window and select paste to run them (make sure to hit enter if the last line doesn't run):

 

net stop immunetprotect

copy /Y "c:\Program Files\Immunet\update\Plugins\update.txt" "c:\Program Files\Immunet\tetra\Plugins\update.txt"

net start immunetprotect

 

3) Now, open Immunet and wait for it to connect to the cloud - once you are connected the Community icon should will turn green and you will see the Community message at the top saying 1 million users protected from 23 million threats. Click the Update button - when the update finishes you should see the update icon change from yellow to green.

------------------------------

Thank you, thank you RobT, I have just followed your cut and paste advice and it does appear to have solved the problem - All is green and :) even my rootkit scan kicked in at last!

Share this post


Link to post
Share on other sites

Thanks RobT. Procedure worked. Bug resolved. Minor point, my version appeared to be 5970 but I suspect that it had been updated but the "About" window does not reflect this. It is still 5970.

Regards

Artedge

Share this post


Link to post
Share on other sites

Greetings all,

 

I have the same problem with version 3.0.1.6056, Plus version.

 

I tried RobT's fix but when i copy and paste the three lines as outlined, on the 2nd one:

 

copy /Y "c:\Program Files\Immunet\update\Plugins\update.txt" "c:\Program Files\Immunet\tetra\Plugins\update.txt"

 

I get a message stating, "The system cannot find the path specified"

 

How did others get it to work?? Please help!

 

I am running W7 Home Premium.

 

 

TIA,

 

 

 

Ray

 

 

P.S. I'm thinking of uninstalling/reinstalling to see if that works but i've heard that some have had problems with the license being recognized. I phoned "support" - the guy i spoke to didn't even know the latest version available - unbelievable!!

Share this post


Link to post
Share on other sites

Greetings all,

 

P.S. I'm thinking of uninstalling/reinstalling to see if that works but i've heard that some have had problems with the license being recognized. I phoned "support" - the guy i spoke to didn't even know the latest version available - unbelievable!!

Hi websurferdude',

The information of the recent update(s) has been almost zero! Official updates should immediately be informed about in three ways in my mind:

1. In the Immunet software itself. Community -> Notices -> Updates

2. At the front page of the Immunet website: http://www.immunet.com/ well visable (not hidden somewhere).

3. As a post in Immunet Forum in the category "Announcements",

This important info options of version updates should also soon be placed in the FAQ category, that will soon be developed again!

Cherers,

sweidre

Share this post


Link to post
Share on other sites

Hi websurferdude',

The information of the recent update(s) has been almost zero! Official updates should immediately be informed about in three ways in my mind:

1. In the Immunet software itself. Community -> Notices -> Updates

2. At the front page of the Immunet website: http://www.immunet.com/ well visable (not hidden somewhere).

3. As a post in Immunet Forum in the category "Announcements",

This important info options of version updates should also soon be placed in the FAQ category, that will soon be developed again!

Cherers,

sweidre

 

 

I downloaded the latest version (.6056), yet when you look at the details of the file, it says version 2.x! Can't someone put the correct version down in the file being downloaded for installation??

 

Also, i run a software update program that informed me today there was another version available (.6112) However, i can't find that version anywhere on their website. The latest one, apparently, on their website is the .6056 version because i tried to do an upgrade but the installer told me i already had that version installed. I did read somewhere in the forums that there was a version .6112 but i'll be damned if i can find it!!

 

These guys need to put their sticks on the ice - the ineptitude is mind-boogling!

 

Luckily, i only paid $15 for a 2 year subscription.

 

 

 

Ray

Share this post


Link to post
Share on other sites

I downloaded the latest version (.6056), yet when you look at the details of the file, it says version 2.x! Can't someone put the correct version down in the file being downloaded for installation??

 

Also, i run a software update program that informed me today there was another version available (.6112) However, i can't find that version anywhere on their website. The latest one, apparently, on their website is the .6056 version because i tried to do an upgrade but the installer told me i already had that version installed. I did read somewhere in the forums that there was a version .6112 but i'll be damned if i can find it!!

 

These guys need to put their sticks on the ice - the ineptitude is mind-boogling!

 

Luckily, i only paid $15 for a 2 year subscription.

Ray

Hi Ray,

I hope, that somebody knowing the paid version will reply on this thread! I only use Immunet Cloud Only version!

First I tried to overwrite my existing v.3.0.1.6056 by getting the new version from http://www.immunet.com/ , but I got a message, that I already have version 3.0 installed.

So I tried this method instead:

1. I uninstalled v.3.0.1.6056 completely using Your Uninstaller (shareware). In fact, I could have used Revo Uninstaller (freeware) as well!

2. I went to http://www.immunet.com/ and pressed the Download button (no version number was written on it, but I downloded anyhow!) and got the newest version downloaded.

3. I installed the new version (option 1: Cloud only version Free)

4. When installed I found that I have received the latest version v.3.0.1.6112! (Good!)

5. As I had done a clean installaion, I had of course to do the settings from scratch (minor exercise)

Note, this method worked really good for my Immunet Cloud-only version!

Cheers,

sweidre

PS. http://www.immunet.com/ has evidently always the latest version, even if the version number does not appear anywhere on the website! DS.

Share this post


Link to post
Share on other sites

Sweidre,

 

Tack så mycket för ditt intresse för min svåra situation!

 

Jag är bara orolig för att göra en avinstallera / installera kommer paraplyvagn upp licensieringen av produkten - Jag läste på forumet någon hade samma problem.

 

Jag antar att jag kommer vänta ett par dagar och se om problemet åtgärdats. Om inte, kommer jag bita ihop och installera.

 

Tack igen, och hälsningar från Kanada till Sverige!

 

 

Ray

 

 

P.S. Jag använder "Google translate" - gjorde det göra ett bra jobb med översättningen?

 

 

 

 

Sweidre,

 

Thank you very much for your interest in my plight!

 

I'm just worried that doing an uninstall/reinstall will bugger up the licensing of the product - i read on the forum someone had the same problem.

 

I guess i will wait a few more days and see if the problem is rectified. If not, i'll bite the bullet and reinstall.

 

Thanks again, and greetings from Canada to Sweden!

 

 

Ray

 

 

P.S. I am using 'Google translate' - did it do a good job of translation??

Share this post


Link to post
Share on other sites

Hi Ray,

It seems, that Google Translate has really improved! There was only one strange translation of "bugger" into "paraplyvagn" : "Paraplyvagn" I have not heard anybody saying. My translation of it back to English will be "umbrellawaggon". I understand, that it will sound strange also in English!

Never mind! OK, you have the paid version, so maybe it will advisable to wait for a proper reply by any Immunet employee (adminstrator) eg. RobT or Anyhony (US Mountain Time 9-5 Mon-Fri)!

Cheers,

sweidre

PS. By the way, I see that, it was RobT, who started this thread, so I think he will for sure look into this thread on Monday! DS

Share this post


Link to post
Share on other sites

Hi all, just wanted to reply to a few questions:

 

1) There only difference between 3.0.1.6056 and 3.0.1.6112 is in the installer. In the 6056 installer we set c:\Program Files\Immunet\tetra\Plugins\update.txt 0 byte file, which unfortunately broke the update GUI. 6112 does not touch this file if it already exists.

 

2) As long as you are connected to the internet when you uninstall, you will get your license key back and be able to use it when you re-install. I've never seen this process fail, but if for some reason it does and you don't get your key back please send an email to support at immunet dot com with your order number or license key and we will manually reset it.

 

3) websurferdude - my bad, my instructions neglected our old school users who started with ClamAV rather than Immunet. Can you please right-click on your Immunet 3.0 shortcut, select properties, and check what the target points to? If it's:

 

"C:\Program Files\ClamAV for Windows\3.0.1\iptray.exe"

 

you will need to change that second line of my instructions to:

 

copy /Y "c:\Program Files\ClamAV for Windows\update\Plugins\update.txt" "c:\Program Files\ClamAV for Windows\tetra\Plugins\update.txt"

 

Hopefully the above actually is the problem... Thanks for catching this - the origional instructions above have been updated.

Share this post


Link to post
Share on other sites

4) Artedge - if your seeing 5970 you have the beta 1 version installed and should update. Can you please reboot, then open the Immunet interface and hover your mouse over the "About" link at the bottom right - do you still see 3.0.1.5970? If you do please uninstall (select no when asked if you plan to re-install Immunet) and then reinstall with the latest version here: http://download.immunet.com/push/immunet/ImmunetSetup.exe

Share this post


Link to post
Share on other sites

RobT,

 

I still get the error - "path specified not found"

 

I enter the 2nd line as:

 

copy /Y "c:\Program Files\Immunet 3.0\update\Plugins\update.txt" "c:\Program Files\Immunet 3.0\tetra\Plugins\update.txt"

 

That didn't work so i tried:

 

copy /Y "c:\Program Files\%Immunet 3.0%\update\Plugins\update.txt" "c:\Program Files\%Immunet 3.0%\tetra\Plugins\update.txt"

 

Same error given - guess i'll try the uninstall/reinstall route after i try technical "support" (oh boy, if it's anything like the other day, i'm gonna scream!!!)

 

 

 

Ray

Share this post


Link to post
Share on other sites
Guest Orlando

Are you sure that your Immunet path is this: "C:\Program Files\Immunet 3.0\"?

 

Please check manually.

 

Orlando

Share this post


Link to post
Share on other sites
Guest Orlando

Hi everybody,

 

You can fix this problem with Immunet Protect Fix Tool BETA 2, you can find it here.

 

Orlando

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...